Setting up Sky Q with Sonos

  • 15 February 2018
  • 7 replies

I get next to no sound from the Play 1s when using Sky Q. When playing music from my iPhone sound floods through all the speakers and is terrific. But practically nothing when using Sky Q - any ideas folks? Surprised there is nothing on here already ...

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Userlevel 7
Badge +21
What do you mean? I have SkyQ and it connects to my Playbase via optical, is that your set up?

If so have you checked the setting in Sky q so that it sends Dolby Sound, the default is stereo. Or are you sharing sound to other speakers?
Hi Bockersjv, thanks very much for your reply.

I have an optical link between my Sonos playbar and the Sky Q box. The Sky Q audio options are Normal/DolbyDigital/DolbyDigitalPlus. We've got a 2TB box so theoretically it should be plumbed into DolbyDigitalPlus - I've tried all three options.

The sound coming out of the Playbase is okay but nothing special and not that much better than the LG TV's own speakers. There is no sound coming out of the two Sonos 1s except during adverts when some kind of surround sound kicks in.

Whole set up will play music streamed from iPhone and sounds great with really good base tones coming from the Playbase.

It's a real puzzle, as if the SkyQ can not properly output 5.1 surround sound .,,
Userlevel 7
Badge +21
Ok, I have the same but with a Sony TV and no surrounds, so it may be the surround set up that is causing the discrepancy.

In my own case the difference is day and night between the playbase and TV. I have settings as Dolby Digital on the SkyQ box (I think, ill check when home), but the optical cable is connected to my TV, which is passing through from the HDMI and Sky. It works well with rich sound the same as when playing music from the Sonos App. I did set it optically with the Sky box and it was the same, but this meant re-jigging connections when I wanted to Play a DVD.

Have you tried your set up using the TV optical out? Be sure to check the TV settings too so they match the Dolby mode for the optical.
It's a brand new LG so age shouldn't be an issue for that or the Sonos items which are also brand new.

I've now connected the optical cable from the Sky Q box to the Sonos. We don't bother with a DVD player so that's fine.

So I can play music from my iPhone and it will sound through all three speakers and is awesomely good, terrific balance across the whole room.

But no matter how I configure the tv/sonos/sky q box, I can't get the same output to all three speakers as when playing from the iphone.

Any ideas?
Userlevel 7
Badge +17
You can check in the sonos app what the playbar is getting, DD5.1 or stereo.
You need to play something on skyQ that DEFINATELY HAS DD5.1, probably only a film from sky cinema. If sky is only sending stereo, than the play1's will do nothing, or some simulated surround (not sure how you get playbase to do that as I don't own one)
The Playbar is getting DD5.1 so can only assume Sky don't broadcast in 5.1?
Badge +1
The Playbar is getting DD5.1 so can only assume Sky don't broadcast in 5.1?

I’m guessing you’ve bought a LG 2017 OLED model? Do you just have the Sky box plugged into your TV? You are best taking the audio from the optical out from you TV to the Sonos than direct from the Sky box if you have multiple sources connected Set your Sky box audio to just Dolby Digital. DD Plus is for Atmos which Sonos don’t support.