Samsung TV Q7DT connected to Arc on TV power up no sound from Arc

  • 9 December 2021
  • 5 replies

Has anyone experience the issue with the TV switching back to TV speakers on powering up of the TV.

Connected the arc to HDMI (eARC) of the TV and have the appropriate settings. All is working great. Once I’m done watching TV for the day I turn only the power to the TV off. The next day when I turn the TV power back on, the sound only comes out of the TV speakers. Need to go to the TV setting to set the HDMI port again and physically remove and re-plug the HDMI cable to the arc for the sound to come back on. Samsung is indicating that it is an arc issue.



Best answer by Ken_Griffiths 10 December 2021, 03:06

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies


It might be the case that the CEC focus is being lost - are there any other devices connected to the TV HDMI ports and if so, does the issue go away if you unplug all those other devices?… (everything except the Arc).

Yes, when I unplugged the other devices the issue goes away. What you mentioned about the CEC focus is being lost sound like it.

I have a bell 4k box plugged in one of the TV port as well as an IPTV box plugged in another. Is there a solution for this? I will need to have those plugged in.



Yes, there are ways to resolve this - first of all perhaps see if there are any TV software/firmware updates and any updates for your connected devices. Then try this… 

  • Power off (not standby) all devices for 3 minutes.
  • Bring TV back online and then the Sonos Arc/Surrounds
  • Next, connect and power ‘on’ one ‘other’ connected device and see if problem returns. You may need to test this for a short time to see if the issue returns.
  • Attach next device to TV and repeat. Again see if the issue returns and continue in an effort try to identify the problem device. 

If a device is identified as stealing the ‘focus’ away from the Sonos Arc, then switch off HDMI-CEC on that connected device. Note that some devices may not allow CEC to be switched off via its settings, in which case you can consider inserting a CEC-Less adapter between the device and the TV. See this link:

Thanks a lot. Will give it a try.

Hi I tried the suggested steps of bringing the other devices on one at a time as well as testing for a short time and was able to narrow it down to one.