Question

Samsung TV KS (2016) version issues with the Playbar


Firstly, I was able to setup the samsung smart remote with successfully with the playbar, I can turn down/up volume on the playbar with the smart remote - so far so good. The volume control works 100% fine. However, the TV will instantly exit any open application when I use the volume controls. I.E. if I am watching a series through the HBO app and try to adjust the volume with the smart remote, the TV will exit the app and go to cable tv...

I have been searching for a way to solve this problem without success... Anyone able to help?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

16 replies

Did you use the following process for the setup?

https://sonos.custhelp.com/app/answers/detail/a_id/2424/~/configure-sonos-playbar-with-samsung-smart-remotes
Exactly, yes.
Hi KIM_4, I am not able to control the volume on the playbar with the samsung, as the remote does not send IR signals, so could you please explain in a bit of detail how you got the the playbar to work with your KS TV. Approciate your help.

Also I beleave the link above is only for F and H series which has an IR emitter option.......
Hi Kim_4, I just ordered a KS8000 TV and the playbar, I am also very curious about how you got the playbar to work with your KS TV, many thanks!
Badge
it wont work u have to use a remote control with IR, 'im using my old sammy remote i barely use the one provided with the KS
Sorry for reviving an old thread. But I just got a KS8000 (euro model) - and after some tweaking it was perfectly possible for me to figure out how to configure the TV remote to work Sonos.

Push home button on remote -> sources -> configure universal remote -> new device -> home cinama -> search for sonos -> choose a hdmi source as device. The logical step here would be to choose optical - but that wont work. For me the TV remote on my UE75KS8005 now works perfectly for controlling my volume.

I must say - this TV is awesome with the Sonos soundbar. It can convert audio to DD 5.1 from any other format I've tested so far.
Badge
MichaelBusse -- I have the 65" version of the KS8000 and just ordered a PlayBar & Sub. Thanks for the instructions I will follow those when I set mine up.

Did you simply have to set up DD 5.1 passthrough on the TV and follow those steps to get the remote working? Also have you tried other 5.1 sources outside of the apps on the TV? I run all of my content through a Roku Premiere+ and I'm hoping things like Netflix, Hulu, Vudu etc. will pass the 5.1 correctly to the PlayBar.
Yes - I simply configured the TV audio to use the optical port - and in expert settings i specified Dolby Digital on the TV.. And set an audio delay of about 100.

Of sources I have tried so far (have only had the TV for a day) is the Plex TV app, my HTPC, Netflix (both TV and PC app) and Youtube. All those have worked without any problem. Even when playing DTS sources from the Plex app or the PC.

I am from Denmark, though. So this is the euro model of the television. But I assume there is little difference, if any.
Badge
Thanks, appreciate it.
Badge
For the record mine worked flawlessly using the technique MichaelBusse suggested. I am able to control the volume of the Sonos using my KS8000 remote.
Hi Michael,

I'm really struggling to get any sound from the TV to my playbar via the optical output. Also called sonos who that it's a problem with the TV and probably have to talk to Samsung.

Could you give a step by step how you set it up to work? I have the remote working with turning up and down the music I play is the sonos app, but that's it..

Appreciate the help and I'm super confused on how to get this going.
I. Got an un75ks8000 model bought in Greece (I'm Danish though...) *

Thanks a million
Mikael
Hi Mikael,

Sure, this is my exact setup.. As you've got the remote working, I'll only describe the sound-menu setup.

Settings -> Sound -> Speaker -> Optical
Settings -> Sound -> Expert Settings -> Sound Format -> Dolby Digital
Settings -> Sound -> Expert Settings -> Audio Delay -> 120

If this does not give you any sound, I'd try and double check the optical cable. If it still does not work, then maybe Sonos is right, it might be an issue you need help from Samsung with.

Hope you get it working 🙂
Thanks Michael,

Note that the TV only gives me the options PCM or 2:5 dts neo, Dolby Digital not an option, any of the two mentioned that may work also for you?

As for optical cable tested with a PS4 and works.

Thanks for trying to help out.

Mikael
Userlevel 7
Badge +21
If your TV doesn't show a Dolby Digital option, then your TV model doesn't support passing Dolby Digital audio through to the optical connection.

If it shows it but it can't be selected, then you first need to have a source sending Dolby Digital audio to the TV. Then you should be able to select it from the Sound settings.
Hi Mike V

It cannot be selected and probably the TV signal I get from my normal regular TV antenna and digital via air, may not be in surround - is the only way to get sound from my Playbar if I can get a surround signal from the TV? On my 5 year old Samsung 55" tv, there was no special tweeking - anything that came via the optical came out of my Playbar.

Ideas' ?

Mikael
Userlevel 7
Badge +21
Selecting PCM should allow the Playbar to get sound, though it won't be true 5.1 surround sound (the Playbar can simulate surround sound pretty well from a stereo signal).