Answered

Samsung Smart TV Remote



Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

59 replies

Userlevel 1
Badge +1
Just to also confirm, this didn't work for me either. I checked the remote and there is definitely a IR light flashing away when pressing the volume up button.

If you get the IR when sliding the volume button up, down, and pressing it for mute, than you should be able to have the PLAYBAR learn it. Try turning the TV off and see if the PLAYBAR can learn the commands like that. I just checked again and for the model of the smart remote we have in the lab it worked just fine on the PLAYBAR.

One more step to take if you've set the JVC as the home theater type and still aren't getting IR from the remote on volume is to select that JVC configured device in the universal remote setup and then select to add a Bluray player to it. Choose JVC again and you should get IR now.

Again, the way to check is by looking at the remote through your phone's camera.


Ok thanks. Adding the BR worked, but because you have to assign it to a HDMI port, it makes this a very messy solution. i.e. I have FireTV on port 2, so the volume will not work.

So this is a Samsung issue. They need to add an option to always send IR Volume or something like that.

Anyone know the right Samsung forum to post this issue?
Userlevel 7
Badge +26
Ok thanks. Adding the BR worked, but because you have to assign it to a HDMI port, it makes this a very messy solution. i.e. I have FireTV on port 2, so the volume will not work.

You may be able to use a Component or AV slot for the BR without using an HDMI slot.
Userlevel 4
Sadly, by configuring the Samsung smart control to send JVC or Bose IR signals, and then teaching that to the Playbar, means the Playbar no longer responds to my other (regular IR) Samsung TV remote controls.

Including, super importantly, the one my wife prefers.

Hence feature request:
* After learning the first remote control, give me the option to learn another.
Userlevel 7
Badge +26
I'll pass on the request for you inopinatus.

Can you give something a try, this might not work on all of the versions, but try deleting out the configuration above with the JVC home theater and player. Then added in a new home theater device, Samsung brand, connected via the AV. Make sure in the TVs settings you've turned off the TV speakers, and let us know if you're seeing IR there.

This may turn on the IR for the smart remote, and hopefully have it using the same IR codes as the standard remote. Just a note, when you do the power test, choosing "No" will have the remote try different IR codes for power, so if the IR is on with that setup, but both remotes are using different commands, try setting up the Samsung home theater device again and choose "No" for that power test a couple times to cycle through the different code options.
Userlevel 4
I'll pass on the request for you inopinatus.
thanks!

Can you give something a try, this might not work on all of the versions, but try deleting out the configuration above with the JVC home theater and player. Then added in a new home theater device, Samsung brand ... cycle through the different code options.
Good idea. Tried it. No joy. Sorry. Confirmed with data from /jffs/irconfig.txt, all the Samsung home theatres (at least those I could find to configure through the Series 9's universal remote setup) have different codes to the regular IR control. Quite a wide variety too, seems Samsung couldn't make up their mind.
Userlevel 7
Badge +26
@inopinatus, oh well. It was worth a try. Way to go checking out the local diagnostic to see the IR code 🙂
I've been struggling with this same Samsung smart remote issue for awhile now. I've tried the various ideas on this thread but have not found a solution that works. Was there ever a resolution???
Userlevel 7
Badge +26
We've been working with this remote for a little while and have done some testing to come up with a couple solutions that work. The goal is to get the remote to use IR for the volume controls, which from what we've seen seems to be the last choice in the programming.

How to test you're getting IR? To test that you're getting IR hold the remote under your phone's camera and look for a couple purple/pink lights that turn on when you press the volume button in any direction.

We've been working with these remotes more and have created an FAQ on our support site to include full directions for using the Samsung Smart Remotes with Sonos. If you have any questions or trouble, please follow the steps here.

Thanks everyone for helping out here, this was a community effort!
I'm having same trouble with Samsung remote and would love a straight forward fix if anyone could solve it...;)
my tv is a UE49KS9000 and does not have RCA input or component. I cant get none of previous suggestions to work.
Userlevel 1
Badge
Hi John, from looking up some information on this TV I was not able to find any optical audio outputs on the TV or the box which connects to the TV, just to confirm were you able to hook up this TV to the PLAYBAR?
Hi John, from looking up some information on this TV I was not able to find any optical audio outputs on the TV or the box which connects to the TV, just to confirm were you able to hook up this TV to the PLAYBAR?

hi Craig, the optical is on the end of the one connect box opposite end to the usb, and yes playbar sound great.
Hi John, from looking up some information on this TV I was not able to find any optical audio outputs on the TV or the box which connects to the TV, just to confirm were you able to hook up this TV to the PLAYBAR?

hi Craig, the optical is on the end of the one connect box opposite end to the usb, and yes playbar sound great.


Also I'd like to say this tv comes with 2 remotes a standard type and a slim one which is pictured in one of the earlier comments,
the standard remote works on playbar fine along with sky remote its the slim one that wont work the sound, and sods law its the slim one i most like to use.🆒
You are all missing a key step. Add Samsung home theatre device and select optical. Do the power test and when it asks if it worked select No. Notice the message at the top of the screen changes and it will ask you to power test the device again. Select yes! It is this that then turns the IR on. Then add the remote for the playbar as per the normal process.
Like many people in this string, i periodically tried again and again to set up volume control on a Samsung Smart TV controller for the Playbar, following instructions on sonos.com and in tech forums. I finally just started playing around with settings and made this discovery. When I changed the source for the Samsung and the Sonos components to HDMI, instead of Optical, the volume control worked immediately. (I did not try changing the settings independently, so if may have been only one that needed to be changed.)
I have the Samsung UN75KS9000FXZA and can confirm this thread helped get me working.

Process went something like this:

Press Home Button on the remote.
Apps will be displayed across bottom of the screen.
Press the left arrow until you get to Sources.
Select Universal Remote (you'll have to push up once then left a couple of times).
Add a Home Theatre - JVC.
It'll do a power test, say yes.
In Sonos go to Room Settings | Select Room | TV Setup and Control | Remote Control Setup | Follow the wizard.

If that doesn't work you may need to adjust the settings inside the Samsung Universal Remote app. I had an Apple TV source, which now says Apple TV-JVC like they 2 devices are joined together.

Hope the helps!
Like many people in this string, i periodically tried again and again to set up volume control on a Samsung Smart TV controller for the Playbar, following instructions on sonos.com and in tech forums. I finally just started playing around with settings and made this discovery. When I changed the source for the Samsung and the Sonos components to HDMI, instead of Optical, the volume control worked immediately. (I did not try changing the settings independently, so if may have been only one that needed to be changed.)

Worked for me as well !
I managed to get this to work much simpler than this but it isn't obvious.

1) Go to the universal remote setup on the Samsung tv.
2) Type Sonos in the brand manufacturer selection box and select it.
3) When it asks if it powered off just select yes.
4) Now this is the key part...go back to the universal remote setup and select one of the other input devices, there should be an option that says use with home theatre select this option.
5) Do this for all of your active inputs.

Having to do those last two steps is not obvious.

This worked for me let me know if it worked for you.
Sorry I forgot to mention one part, select the input as Optical as you would expect, as this is how the Sonos is connected.
Daveharc,

After trying all of the other suggestions in this thread, finally your solution works for my 2016 Samsung TV.

As an aside, the process will rename your input devices, for example, SKY becomes SKY-SONOS, BD becomes BD-SONOS. You are able to edit this though, and revert the name back to its original, to keep it all looking neat.

I've had the fix for a couple of days, and can confirm this sorts all channels including native apps etc like Netflix.

Thank you!!
Thank you so much community I have the SHUD 9500 Samsung 2016 curved 65in this has been an issue for weeks. Adding the Samsung as a sound system works great but I lost some TV functions in the remote. But found a way around that to.
Can also confirm as a new Ks8000 owner, this definitely worked. My Apple TV, XBoxOne and Cable inputs all work with the tv remote and volume controls the Playbar.

I managed to get this to work much simpler than this but it isn't obvious.

1) Go to the universal remote setup on the Samsung tv.
2) Type Sonos in the brand manufacturer selection box and select it.
3) When it asks if it powered off just select yes.
4) Now this is the key part...go back to the universal remote setup and select one of the other input devices, there should be an option that says use with home theatre select this option.
5) Do this for all of your active inputs.

Having to do those last two steps is not obvious.

This worked for me let me know if it worked for you.
Yes @daveharc, thank you. This works for my Series 8. I had an Apple TV connected and switched it's output to Home Theatre. Now both remotes work (the Curvy one and the old fashioned IR one). I am not sure how you would do it if you did not have an additional device connected to the TV but I am up and running.
One further note. When the Samsung TV is off, the old fashioned IR remote still controls the volume. The curvy one does not, which is not surprising since I suspect that the TV's Connect is pumping out the iR to the PLAYBAR.
Userlevel 4
As of a recent Samsung software update for my KS9000 I can now control the Playbar volume from both the Smart Remote and the IR remote. Hurrah!

Setup procedure:

With the Samsung Smart Remote:
1. Click the Home button and navigate to Source -> Universal Remote.
2. Select New device -> Home Theatre
3. Enter "Sonos" as the brand, attached via Optical.
4. Do the power on/off test. Tell it Yes and click Done.

Now in the Sonos App:
5. Go to Settings -> Room Settings -> Playbar -> TV Setup and Control
6. Select Remote Control Setup -> Add/replace current remote
7. Follow the prompts to program it with the Samsung Infrared (old-style) Remote Control.
DO NOT USE THE SMART REMOTE FOR THIS STEP.

And after these steps I now find that the IR blaster on the Smart Remote sends the Samsung IR Volume Up/Down/Mute. It is mixed in with some other codes, which is why you have to use a classic Samsung IR remote when programming the Playbar.

You can now select "Use With Home Theatre" when configuring other sources on the TV, to activate Playbar volume control for external sources like Apple TV, PS4, cable STB &c.

I had been badgering Samsung to update their IR code database to do exactly this. I know others have as well. Perhaps we finally got through to someone able to make a difference. It's definitely a change they made in the last few weeks.

As others have noticed, the smart remote only functions when the TV is powered.
As of a recent Samsung software update for my KS9000 I can now control the Playbar volume from both the Smart Remote and the IR remote. Hurrah!

Setup procedure:

With the Samsung Smart Remote:
1. Click the Home button and navigate to Source -> Universal Remote.
2. Select New device -> Home Theatre
3. Enter "Sonos" as the brand, attached via Optical.
4. Do the power on/off test. Tell it Yes and click Done.

Now in the Sonos App:
5. Go to Settings -> Room Settings -> Playbar -> TV Setup and Control
6. Select Remote Control Setup -> Add/replace current remote
7. Follow the prompts to program it with the Samsung Infrared (old-style) Remote Control. DO NOT USE THE SMART REMOTE FOR THIS STEP.

And after these steps I now find that the IR blaster on the Smart Remote sends the Samsung IR Volume Up/Down/Mute. It is mixed in with some other codes, which is why you have to use a classic Samsung IR remote in step 7. You must now select "Use With Home Theatre" when configuring other sources, to activate Playbar volume control for external sources like Apple TV, PS4, cable STB &c.

I had been badgering Samsung to update their IR code database to do exactly this. I know others have as well. Perhaps we finally got through to someone able to make a difference. It's definitely a change they made in the last few weeks.

As others have noticed, the smart remote only functions when the TV is powered.


Are you able to control PLAYBAR volume/mute from the Smart Remote when the TV is turned off - i.e. you are listening to music on Sonos?