Samsung QE65QN95AATXXC + Sonos Arc = Sound cutting


Badge

I realize that there are several threads similar to this, but none towards this exact European Samsung-model.

I bought the Sonos Arc surround package a couple of weeks ago. Spent a lot of time trying to sync the audio with my LG 65” OLED B7V, but there was just no chance.

Decided to purchase the new Samsung QE65QN95AATXXC hoping this would be a good match. At first it seemed to work perfect. But all of a sudden the sound cutting happend.

Been in contact with both Sonos and Samsung supprt today. Neither could or were very willing to help.

  • Sonos says it is a Samsung issue, and that they resolved it with firmware 1462.1, and that I had to contact Samsung for further assistance.
  • Samsung said they didn’t know about a specific issue with this model and that there were no patches in their system to help me.

My setup:

  • Sonos Arc connected to Samsung OneConnect HDMI 3 (eARC) with Sonos HDMI-cable
  • Nvidia Shield connected to Samsung OneConnect HDMI1 with new 8K HDMI 2.1 cable

My settings:

  • eARC on Samsung = Auto
  • HDMI Input Signal Plus = ON @ HDMI 1 and 3\
  • Audio setting: Passthrough
  • Sonos app i reprorting Dolby Atmos both with Passthrough/Auto. But there is a lip sync issue with Auto.

My firmware:

  • Sonos: 13.0.4 (newest)
  • Samsung TV: 1057 (newest)

Observations:

  • Sometimes the audio cuts out several times within a very short period of time. Sometimes it seems to be when there is a huge action scene which could make us think it is a bandwith issue. But the next time this happens it might be during a quiet talking scene.
  • Mostly it cuts out at an interval of approx. 10 minutes.
  • Each sound cut/drop is 2-3 seconds
  • Power cycling the TV/Arc/Shield does not affect anything. Neither does toggling settings.
  • When switching from Passthrough to Auto, the audio goes slightly out of sync.
  • When in AUTO-mode it seems like the drops are not happening, but sometimes there is a “cracking” sound in what is presented from the Sonos Arc. Maybe this corresponds with when the audio would cut out if in Passthrough mode?

Is there any hope for us? 


10 replies

Badge

Update:Audio cuts even though the media is not Dolby Atmos.

Userlevel 7

A user on another thread suggested this:

1. Enable Input Signal Plus on all HDMI sources.

2. Disconnect all HDMI cables from the One Connect box.

3. Unplug the One Connect from power.

4. After about a minute, reconnect the HDMI cables then plug the One Connect box back into power.

5. Hold power button on the TV remote for 10 seconds until the TV restarts.

 

Userlevel 6
Badge +16

Hi @stian89 

Welcome to the Sonos Community!

Have you had a chance to try @GuitarSuperstar’s suggestion?

If so, and it helped, could you please mark it as Best Answer? If you want to wait a few days before judging, that’s fine. Thanks!

Badge

A user on another thread suggested this:

1. Enable Input Signal Plus on all HDMI sources.

2. Disconnect all HDMI cables from the One Connect box.

3. Unplug the One Connect from power.

4. After about a minute, reconnect the HDMI cables then plug the One Connect box back into power.

5. Hold power button on the TV remote for 10 seconds until the TV restarts.

 

Thanks for the suggestion! I am currently on vacation! Will be home in 9 days. Eager to try this. Really hope this will prove to be the solution!

Badge

A user on another thread suggested this:

1. Enable Input Signal Plus on all HDMI sources.

2. Disconnect all HDMI cables from the One Connect box.

3. Unplug the One Connect from power.

4. After about a minute, reconnect the HDMI cables then plug the One Connect box back into power.

5. Hold power button on the TV remote for 10 seconds until the TV restarts.

 

Tried this, but it did not solve my issue. :( Got two sound drops during a 40 minute episode (playing in Dolby Digital Plus 5.1). Diagnostic: 886794340 and 1090785454.

Userlevel 6
Badge +16

Hi @stian89 

The Arc is reporting conflicting information (it says it’s playing DD+ but via optical, which isn’t possible). I think therefore the best thing to try is a reboot of the Arc - please switch it off (or unplug) for at least 30 seconds or so.

Test once more, and if that hasn’t improved matters, I would suggest the following:

  1. Remove the surrounds from the Arc (Settings » System » Stue » Remove Surrounds)
  2. Put the TV into Standby
  3. Disconnect the Arc from the TV
  4. Factory reset the Arc (https://support.sonos.com/s/article/1096)
  5. When the Arc is flashing green, the app will detect it within a minute or so
  6. Add the Arc back on to your system
  7. During the Arc’s TV setup, connect the HDMI cable when the app asks you to (and not before)
  8. Bond the surrounds back to the Arc
  9. Test again

I hope this helps

Badge

Hi @stian89 

The Arc is reporting conflicting information (it says it’s playing DD+ but via optical, which isn’t possible). I think therefore the best thing to try is a reboot of the Arc - please switch it off (or unplug) for at least 30 seconds or so.

Test once more, and if that hasn’t improved matters, I would suggest the following:

  1. Remove the surrounds from the Arc (Settings » System » Stue » Remove Surrounds)
  2. Put the TV into Standby
  3. Disconnect the Arc from the TV
  4. Factory reset the Arc (https://support.sonos.com/s/article/1096)
  5. When the Arc is flashing green, the app will detect it within a minute or so
  6. Add the Arc back on to your system
  7. During the Arc’s TV setup, connect the HDMI cable when the app asks you to (and not before)
  8. Bond the surrounds back to the Arc
  9. Test again

I hope this helps

Thanks for replying! Unfortunately it didnt help. Two drops within a minute or two from each other. After 15 minutes of Dolby Atmos content. First: 1356680773, second 1052625710.

 

Userlevel 6
Badge +16

Hi @stian89 

Thanks for trying those steps.

Could you please try disabling the CEC features on the nVidia Shield? Settings -> Device preferences -> Display & Sound -> Power Control. Alternatively, just disconnect the Shield from the TV.

Reboot the TV (unplug) afterwards and test. If it hasn’t helped, please re-enable the features (it allows the TV to switch on or over to the Shield when you ‘cast to Chromecast, for example).

Finally, I can only suggest that you try swapping the ends of the Arc’s HDMI cable round - maybe there’s a “dry” or marginal connection on one of the pins. Try another cable, if you can.

If that doesn’t help, I recommend you get in touch with our technical support team again. Please let them know that according to Samsung this model of TV was unaffected by the recent firmware issues on other Samsung TVs. It may help to refer them to this thread too.

 

Badge

Thanks for your reply. :) Tried all the new steps without any success unfortunately.

I sent the following to Sonos Technical Support:

 

I have done some more testing.
The audio only cuts out when playing from Shield TV, not from the Plex TV app (although sometimes there is a small audio glitch when playing from the TV. Like a cracking sound.

The difference from internal TV to Shield TV is that the TV audio setting is in AUTO when from internal TV. On Shield TV it is set to Passthrough.


I have tried the following:

- 2 different HDMIs, both for Shield TV Pro and Sonos Arc (I bought two new expensive 8k HDMI 2.1 cables).

- I have swapped the ends of those same cables (change which end goes in which device).

- I have tried the trick with HDMI Input Plus Signal (then removing HDMIs, removing power from TV, wait, plug in HDMIs, plug in Power, reboot TV with 10 second on the Power button). This trick resets most of the HDMI Input Plus sources afterwards, so I have to turn that setting on again afterwards anyway.

- I have tried turning off the CEC features of the Nvidia Shield Pro.
- I have removed the surrounds from my arc, disconnected it from my TV and factory reset the Sonos Arc. Then added it all together as shown in the app..

- Removed power from all devices for minutes.

- Shut down all other apps on the Nvidia Shield.

 

When does it work?

- When I am playing content which is PCM or Dolby Multichannel PCM, from any source. There is no audio drop. Even when the TV is set to passthrough.

- When I change from Passthrough to Auto on the TV, there seems to be no audio cuts. But sometimes (not often) the audio glitches. Like a small cracking noise. The problem with AUTO is that when I play content from the Nvidia Shield Pro in Auto, the lip sync is off and I am not able to match video/audio. Even when I change this from 100 to 0 on the Samsung TV.

 

Problems / observations:

- When playing content from the Plex Samsung App, almost all content is showing as Dolby Multichannel PCM when in eARC = Auto. When I turn eARC = Off, most content change to Dolby Digital Plus 5.1 in the Sonos App.

- The sound cutting happens both when eARC is in AUTO and OFF (from Shield). 

- The sound cuts on both Dolby Atmos and DD 5.1 It is only PCM which is "safe".

 

Testing:

I found two movies/shows that show up as Dolby Atmos from both the Samsung App and from Nvidia Shield. It feels like the audio is better in Passthrough than when it is set to Auto. Here are my observations:

Settings Shield:
Audio Output: Auto

Dolby Audio Processing ON
DTS Off

Settings Samsung:
eARC: Auto

Audio: Auto

 

1. Watched the first movie on Samsung Plex App for 37 minutes. No audio cutting. No glitching.

 

2. Changed to Shield TV and changed from Auto to Passthrough.
After 9 minutes the first audio cut happened. Diagnostics: 1661171794.

13 minutes later the next audio cut happened: Diagnostics: 1133793596.

 

After this point I tried the HDMI Inputs Plus signal trick mentioned earlier.

I also swapped which end of the HDMIs goes in which device.
All 3 devices power plug removed for minutes.

 

3. Tried playing a new movie from the Samsung Plex app again (Dolby Atmos). No audio cutting, but what felt like an audio glitch happened right before diagnostics: 1222914398.

 

4. Played the same movie on my Shield. Audio cut after 10 minutes (no diagnostics).

 

5. Still playing from Shield TV I changed from Passthrough to Auto. The audio is now out of sync, but there is no audio cutting. I was not able to get audio/video in sync, even at det lowest setting in the Samsung TV (from 100 to 0).

 

6. Changed settings to: eARC: Off and Passthrough. Still playing Dolby Atmos from Shield. Audio cutting after 8 minutes. Diagnostics: 1912372364.

 

7. I set eARC back to Auto and swapped back to the Samsung Plex App. Now there was no sound coming from the movie at all. Tried switching between different settings. eARC OFF and PCM made the Arc play the audio. All other settings were silent. Had to reboot the TV (10 seconds from the remote) to make the audio work again.

 

8. Got a new cracking sound from the Samsung Plex App. Diagnostics: 1571315200.

 

Conclusion:

I don't know what else I can try to make this work. This just isn't acceptable with the kind of money spent on the new TV and Arc setup.

- Playing content from the Samsung Plex App is not an option for me: The app is slow, doesn't support all 4K content and mixes most sound to PCM Multichannel.

- Shield TV handles all formats and is a lot quicker than the apps on the TV. So this is my main home theater and it has to work.

- Shield TV in auto is not an option. Lip sync issues make me want to throw the TV off the balcony.

- PCM is not an option.

- I can't keep spending tons of money on new HDMI cables (I have already tried this once).

 

Userlevel 6
Badge +16

Hi @stian89 

My colleague @Xander P  found this, which seems very relevant:

https://www.reddit.com/r/ShieldAndroidTV/comments/elic3q/shield_2019_atmos_audio_stuttering_cutting_out/

 

Reply