Answered

Problem with Apple TV 4K


Every time I turn on the Apple TV, the audio output defaults to ‘HDMI’ which is the Apple TV itself. I have to switch it to Sonus every time. This is annoying. Does anyone know how to get the apple TV to automatically default to Sonos for audio output?
icon

Best answer by MikeV 4 October 2018, 17:59

There's a setting in the Apple TV settings about controlling other devices over HDMI... Settings > Remotes and Devices > Control TVs and Receivers... try turning that setting off and see if that helps.

After turning that off, you might need to tell the Apple TV how to control volume so the volume buttons on the Apple TV remote work... you should be able to tell it to use Sonos via IR, and that should work without needing to program anything else.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

14 replies

Userlevel 7
Badge +21
There's a setting in the Apple TV settings about controlling other devices over HDMI... Settings > Remotes and Devices > Control TVs and Receivers... try turning that setting off and see if that helps.

After turning that off, you might need to tell the Apple TV how to control volume so the volume buttons on the Apple TV remote work... you should be able to tell it to use Sonos via IR, and that should work without needing to program anything else.
Did this work for anyone? This is an issue that after 3 calls into Sonos support, could not solve. They say it’s a problem with ATV. please help!
I’ve fully brought into Sonos with the beam, sub and two ones in the living room to creat 5.1 experience only for Sonos to continually drop out and Apple to revert to my Panasonic’s terrible speakers. To rub salt in I phone Sonos to find 24/7 support only covers business hours. Feeling disappointed with this experience
24/7 support is available on social media. It doesn't say anywhere that it is 24/7 phone support. Get in touch and I hope that your issue is resolved quickly.
I’m having this problem too. It switches from the Beam speaker back to HDMI - if it’s an apple issue is there a fix for it? How do we keep it from switching off of that and stick to the external speaker? Maybe an airplay fix?
I'm also having this problem. Apple TV defaults to HDMI but if I want the volume to go thru all Sonos speakers, I have to set it each time I turn on the TV. It doesn't hold the setting when the TV is turned off. Seems like a bug but I'm not sure if it's with Apple TV or Airplay.

I, too, have this same problem with my Bean + 2 One SL’s.  Nearly two hours on the phone with Sonos support and they concluded I needed to speak with Apple.  The call with a Senior Wireless Advisor at Apple was much shorter.  What I learned is that because the Sonos speakers are connected to Apple TV via Wifi (except the Beam), I must reselect the audio output every time Apple TV powers up.  Therefore, according to Apple, the Airplay 2 functionality is working precisely as it was designed.  However, nowhere in any Apple or Sonos published literature am I able to see that to use the two systems together, requires the user to select the preferred audio output after each power up.  I find that to be quite misleading from both the Apple side and the Sonos side.  Finally, the Apple advisor suggested I provide feedback at apple.com/feedback adding that if enough people complain about it, maybe Apple will do something about it.

Userlevel 7
Badge +21

@rmbrennanjr - you are using Airplay to get the audio from your Apple TV to your Beam? Why?? Use either ARC (if your TV supports it) or optical out (if it can’t do ARC). You’ll get 5.1 then, instead of stereo.

The Beam is connected to the TV HDMI-ARC. However, every time I turn off the TV and back on again, Apple TV defaults to only the Beam and ignores the One SL’s. 

Userlevel 7
Badge +21

The Beam is connected to the TV HDMI-ARC. However, every time I turn off the TV and back on again, Apple TV defaults to only the Beam and ignores the One SL’s. 


Are the SLs Paired, or Grouped? To work as surrounds they need to be Paired with the Beam.

They are grouped. I am not interested in surround sound but rather just stereo sound amongst the three speakers in an open room. 

Userlevel 7
Badge +21

They are grouped. I am not interested in surround sound but rather just stereo sound amongst the three speakers in an open room. 


Ok that makes a lot more sense now. (Your problem, that is). I think you need to deselect “Ungroup on autoplay” on the Beam, so that when the TV starts up, it doesn’t dump the SLs that are grouped to it.

Thanks for sticking with me on this. However, “Ungroup on auto play” is already deselected. 

Userlevel 7
Badge +21

Thanks for sticking with me on this. However, “Ungroup on auto play” is already deselected. 


Hmm, ok, but I’m not sure where AirPlay figures in your configuration, and I remain perplexed by Apple’s comment “the Sonos speakers are connected to Apple TV via Wifi” so I think there is more to this than meets my eye.