PLAYBASE and Sony TV Output Setting?

Badge +1
I recently got a playbase and using it with my Sony Xbr55x850d. There is an optical output setting on the TV which gives me the options of Auto 1, Auto 2 or PCM. Does anyone know what the ideal setting is for best sound using just the PLAYBASE without rears or sub. I'm ideally looking for Dolby or some sort of simulated surround.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

12 replies

What does it say in the manual for Auto 1 and Auto 2? PCM is generally only stereo.
Badge +1
I was able to resolve this looks Auto 1 setting is ideal because it's passing DD 5.1 to the playbase for content that supports it. Was able to. Verify through the about info on the sonos controller app.
Hi, I have similar issues with the Play Base and my 2 y/o Sony 4K KD-43X8307C. Although I've set it all up according to the 2 manufacturers and your (thank you!) suggestions, I can not get any audio via the Sonos. Any ideas how to proceed? was there a lid on the optical of the Sonos that I should've removed (didn't see any)? Lost for clues - help would be mich appreciated (but Sonos Tech support is closed over the weekend (annoying!)!
Well, there's a couple of things to check. Pull the cable out of the Playbase, while the TV is on, and see if there is a red light coming out of it. If not, either the cable isn't seated in the TV properly, or you haven't set up the audio settings on the TV properly. If there is a red light, plug it back in to the Sonos, and check the TV to see if it is set to only pass Dolby Digital, and not anything else. Probably a good time to check in the same area that the audio output is set to "fixed" rather than "variable".

You'll probably need to go in to the audio settings of each device that is connected to the TV, and lock them down to Dolby Digital as well. That includes cable boxes, DVD/blue ray players, game consoles, and streaming devices like Apple TV.

When the TV is on, go in to the Sonos controller app, under setting, and look at "About my Sonos System". Under the heading of the Playbase, it will tell you if it's receiving a signal that it can interpret, like Stereo or Dolby digital. Might be worth checking, while you're in the controller app, that you've got some volume turned up on the speaker itsel, and that mute isn't on ;)

If none of this works, I'd submit a system diagnostic, and post the number here, or call in to Sonos. You can find their data at
Dear Airgetlam,
many thanks for your kind help!
I've done all of the above.
My controller says
Audio In:
WM: 0
So I guess that says a lot (just not to me, as I don't know how to fix it)
Interestingly, I can control the Sonos via the TV Remote when playing Spotify. Just no TV sounds coming through.
Red light shining, Audio settings are on Audio Systems (as opposed to TV) and output is on variable, and volume is turned on.
I might have to go though your link, Many many thanks!
Sorry, I'm on my iPhone, so I'll be a bit more terse.

If you've got the red light coming through, that's good. It means the TV is outputting something. But the Audio In: line with nothing after it means that the data that is being sent can't be intepreted by the Sonos. Somewhere in the audio settings of the TV set there has to be a place where it indicates/ limits what audio it is processing. I no longer have a Sony, and not being at home, I can't easily pull up the manual for your TV. But we do know the speaker works, since Spotify is working.

You're 90% of the way there. At this point, it's got to be the audio stream or a broken optical input on the playbase.
Good day again,
appears that the optical output from the Sony is very "temperamental". I got to intermittently to work today!
Once again, thanks for your kind help.
Call Sony and talk to them. Also, make sure that you've got the firmware on the TV updated (have I said that before? If not, I apologize, they've released new firmware this year for some TVs that addresses the Sonos issue, I think I read somewhere)

Glad it's (sometimes) working. At least you're aware of where the issue may be. Good luck!
Thank you very much!
I hope you've solved your problem but this may help other Sony TV owners. The settings for the TV are buried pretty far down in the Sony menu. Note: set your TV volume where you want it, usually pretty low or off, BEFORE you start this process. On my TV, Sony KDL-40R510C, which is about a year old and interwebs-ready (not), it's home/settings/preferences/setup (NOT Sound). Scroll past the first page to AV Setup. Change Speakers to Audio System, Audio Out to Fixed, Digital Audio Out to Auto. Hope this is helpful.
Thanks Lexi,
that's cool, just figured it out recently. Indeed a good idea to set the speaker level to low (saved my ears!).