Answered

Playbar: No sound with LG OLED65GX6LA though optical

  • 20 September 2021
  • 3 replies
  • 37 views

Apologies if this has been covered before 

Recently bought a LG TV (LG OLED65GX6LA)  Running the latest Firmware 03.23.35 , and have linked up my soundbar via a optical cable and have two Sonos play ones as rear speakers and a sub and it used to work well. Since september I only get sound via internal speaker.

I control the playbar and my TV using Logitech Harmony.

Adressing the Playbar using the Sonos App Version 13.2.2 and Build 64320120. I can play music as usual but no sound from the TV or via HDMI connected devices via playbar or satelites.

I don’t know what changed, but it’s frustrating not getting any surround sound...

 

icon

Best answer by Airgetlam 20 September 2021, 20:19

View original

3 replies

That suggests either the optical output has failed on the TV set, or that the signal being sent by the TV set can not be ‘read’ by the Sonos, meaning it is no longer Dolby Digital, but perhaps Dolby Digital Plus, or DTS. 

It’s certainly happened before where a ‘background’ update to a TV set or other source device has changed the audio output settings. I’d recommend looking at the TV’s settings to ensure it is locked down to Dolby Digital, and then do the same to every device that feeds the TV a signal. 

The Cable from the tv to the playbar clearly transmits a signal. I set every output to Dolby Digital but still no sound.

Then I would recommend that you submit a system diagnostic  particularly while the TV is on,  and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

Reply