PCM Audio Output on ARC and Amp paired setup

  • 13 November 2022
  • 4 replies

I have My sonos arc connected to my TV which in turn is connected to my Sonos amp. When the TV is outputting anything other than Dolby surround I do not get any audio out of the ceiling speakers connected to the amp.

The sound is only coming from the Arc. On any other system if you are not listening to Dolby output then you still get audio out of the rear speakers albeit only stereo.

Is there something wrong with my setup?

4 replies

I don’t think so. If the signal being sent to the Amp doesn’t have any surround signals as in Dolby Digital 5.1 or Dolby Atmos, the Sonos won’t be ‘upscaling’ the signal and pushing stuff there. 

If you’re streaming music, and not using that TV input, you should be setting the surrounds to Full, rather than Ambient, in the room’s settings. 

Userlevel 7

With most stereo content, the Arc will perform an audio up-mix of the stereo signal to create a simulated surround sound. This means you’ll still hear most audio out of the Arc, but the surround speakers will play what is determined to be ambient audio. But with some low quality stereo sources, you will hear little to no audio from the surround speakers.

Yes that's exactly what I understand but there is nothing coming from the ceiling speakers connected to the amp. Only when there is surround sound coming from the source. Does not seem correct to me.


On my Onkio you always get something on all speakers regardless of the source.


If I listen to a general TV channel using PCM stereo 2.0 output I don’t usually get very much (if anything) from the surrounds or sub - I get some ambient audio with Dolby 2.0 audio in some cases …and lots of output from the surrounds with Dolby/DTS 5.1 surround audio (with or without Atmos). The fact the setup is okay with Dolby surround sound, I think, shows all is likely working as it should be. 

I also get ‘general’ music audio playing from all speakers, as I’ve set the surrounds to ‘full’ (rather than ‘ambient’) music audio playback.

If playing Atmos audio, the surrounds ignore the ‘full’ music audio setting (obviously) and I get the usual immersive audio from all.