No audio on Playbar when playing Hulu, Amazon Prime, and other streaming apps

  • 1 August 2020
  • 7 replies

Userlevel 2

I recently upgraded my existing Playbar sound system with the Boost, and then did the S2 update. However, I do not get sound when trying to play certain streaming channels--such as Hulu, Showtime, Amazon Prime, and others. Other channels like Netflix and HBO Now are fine and I can get sound through my Playbar. I’ve made sure the TV audio settings are correctly set, and I’ve followed all the instructions on this page:

But, still no audio on most of our streaming channels (which we get through a Roku device).  Any advice?

7 replies

Userlevel 3
Badge +9

Hi @Backyard Bungalow, thank you for reaching out.

To understand the issue, we would need to take a diagnostic.

Please while playing any channel that has no audio, take a diagnostic in the Sonos app.

Settings > Help & Tips > Submit Diagnostic and reply with the diagnostic confirmation.

The diagnostic will tell us what audio signal the Playbar is getting.

If you have other concerns, feel free to reach out.


Userlevel 2

Thank you, @Kyle A 

I just submitted the diagnostic report. Confirmation: 465987876

Userlevel 3
Badge +9

Hi @Backyard Bungalow, thank you for taking the time to troubleshoot this. 

I checked the diagnostic, the Playbar and Sub are on a different Household ID.

In this case, the Playbar data wasn’t available in the confirmation number; we would need to correct this.

Let’s Factory Reset the Playbar and Sonos Sub then add them back. Settings > System > Add product.

Once added, Play the channel and take another diagnostic.

Update us on how it goes.

Userlevel 2

Thanks again, Kyle.

I reset the Sub and Playbar and successfully added them back in to the home theater system. I’m able to hear sound on the same channels as before, but not the “problematic” ones.  

I just submitted another diagnostic report, while playing Hulu (that doesn’t have sound). Confirmation # is: 196064969.

Userlevel 3
Badge +9

Hi @Backyard Bungalow, thank you for the update.

I checked the diagnostic, the Playbar is receiving Silence-PCM.

I would like to confirm, is the Playbar connected to the TV and Roku to the TV?

If this is the case, let’s check the audio format setting on the Roku. 

Select either PCM, Dolby Digital 5.1, or Stereo as the audio format; these are the formats the Playbar supports.

Update us with your findings.


Userlevel 2

Thanks for the suggestions, Kyle. I tried resetting the Roku audio settings to the options you mentioned, but when I did that, I got no sound at all on any of the channels we stream. So, I put the Roku audio back to its original “Auto Detect” setting.

So, now I’m back to where I was: with audio only on Netflix and HBO, but none of the others.  Any suggestions?

Userlevel 3
Badge +9

Hi @Backyard Bungalow, thank you for the update and sorry for the update.

We could also test the same channels with the TV’s internal speakers. 

The Playbar is receiving silent audio from either of the two.

If the internal speaker is also silent; it’s the Roku.

If the internal speaker is working it’s the TV-Playbar connection.

Update us with your findings.