No Atmos on Beam 2 from LG C1 TV

  • 15 January 2022
  • 3 replies

I have the same issue as described by this chap - 

But when I look at the setting mentioned (HDMI Input Audio Format) it’s greyed out? Should the TV be prepped by changing a setting before the Beam is plugged in or could there be another setting somewhere that needs tweaking before the above setting becomes available? If it provides a possible clue….when I select the speech enhancement option in the Sonos app, it doesn’t appear to make any difference, well, if it does then it is very, very subtle!


3 replies

Userlevel 4

Do you have any other media device connected to your TV by HDMI or are you using the TV’s internal apps?

In the linked thread, that user was using a Virgin V6 box.


I have a similar kind of thing but mine is the older VM Tivo box. I’m accessing Atmos demos on the TV’s YouTube app. My sockets are occupied thus…


1 - Tivo
2 - Sonos Beam 2
3 - BluRay player
4 - HDMI extension hub with 4 available sockets. Only two are used - one for Xbox 360 and one for Xbox One.

Userlevel 4

The HDMI Input Audio Format won’t be applicable when using the TV’s apps.

It should show available options when using your TiVo/BluRay player/Xbox

I’ll let someone else takeover here as I’m still getting to grips with Atmos capability myself.