Answered

no atmos Dts 5.1 when playing a blue ray

  • 14 November 2022
  • 1 reply
  • 354 views

I have an lg television 49UN711C0ZB

which is connected to my Sonos arc through the earc port and the sound set to pass through to the sound bar.HDMI 1 is set to bitstream and I have connected a Sony input x800m2 blue ray player.

this is my second blue ray player that I have bought 

when playing a film the trailers sound amazing with the Sonos app reporting that they are a 5.1 format

as soo. As the film starts to play the sound quality drops and the effects are reduced.the Sonos app is reporting the sound as stereo.

this is frustrating as I get Arnos and 5.1 when I use any of the tvs built in apps and also 5.1 from my virgin box

can anyone help me with the correct settings as I don’t want to send another blue ray player back

 

icon

Best answer by GuitarSuperstar 14 November 2022, 21:36

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 7

Are you sure your TV is equipped with HDMI eARC or does it just have HDMI ARC? Because eARC is required to get Dolby TrueHD, Dolby Atmos, and Multichannel PCM audio from Blu-ray discs.

If your TV does have eARC:

When playing DTS-encoded discs, set the Digital Audio Output setting on the Blu-ray player to PCM. This will result in lossless “Multichannel PCM” audio playing out of the Arc which is what you want since Sonos doesn’t support DTS-HD Master Audio or DTS:X.

When playing Dolby-encoded discs, set Digital Audio Output to Auto.

Also always keep BD Secondary Audio and Audio DRC set to OFF.