My work around 5.1 via HDMI, Playbar.

  • 16 September 2017
  • 42 replies
  • 10616 views


Show first post

42 replies

Laugh. Ask another hard question.....

There are some TVs out there that have different types of HDMI ports, where one works one way, and others work another.

You're probably 90% correct, but there's that small chance that your TV is different. Easy way to test that, though, is to connect that DVD player that you've tested with to the other HDMI ports on the TV, and check. 🙂
Badge +1
Bought one for my Roku 2, Samsung PS51E6500 TV, when the EDID was installed, the Roku recognised the the device and within the Roku sound settings it said Dolby Digital for the 1st time instead of Stereo! I thought great here we go, however, the TV will not recognise the DD feed, only says PCM which is very annoying. I have the EDID configured correctly on setting E, I also tried the device on another TV with another Roku 2, same again, the Roku recognises the output as DD but the TV only sees PCM, any ideas another before this device goes back to Amazon? Cheers. Oh and the reason I wanted this device was to output DD to my Sonos Playbase....
Userlevel 1
Just FYI,my Sony 46EX653 passes through DD5.1 on all HDMI ports, tested and working using my Sony BluRay Player.

What does not seem to work are the other devices that I have connected to the TV, namely ...

Sky+ HD (Only getting Stereo, even from movie channels)
Roku (Only getting Stereo even when playing DD5.1 demos)
Chromecast (Only getting stereo even when playing DD5.1 demos)

The TV seems to be passing DD5.1 out to the Optical as tested with the BluRay player on all HDMI ports, but the other devices either are not passing DD5.1 to the TV, or there is some other issue.

Any ideas peeps?
Userlevel 7
Badge +21
Just FYI,my Sony 46EX653 passes through DD5.1 on all HDMI ports, tested and working using my Sony BluRay Player.

What does not seem to work are the other devices that I have connected to the TV, namely ...

Sky+ HD (Only getting Stereo, even from movie channels)
Roku (Only getting Stereo even when playing DD5.1 demos)
Chromecast (Only getting stereo even when playing DD5.1 demos)

The TV seems to be passing DD5.1 out to the Optical as tested with the BluRay player on all HDMI ports, but the other devices either are not passing DD5.1 to the TV, or there is some other issue.

Any ideas peeps?


Not really much but -

Maybe those devices aren't really outputting DD 5.1?
Have you tried connecting those via optical directly to the Playbar? - Be worth doing that to see if it's the TV or not. But seems odd it works with Blu-Ray player but not the others. Only other thing is the HDMI cable - try using the one you used with the Blu-Ray on one of the other devices
Userlevel 1
Hey Stuart_W,

Thanks for the reply. Guess I can connect up the Sky+ box direct ... but neither the Roku or Chromecast will allow that. Good place to start though! I also did wonder about the HDMI cables, the DVD player is in a breakfront cabinet three meters away from the TV and the cable runs under the floor. It would be a B1tch to lift. Got some other HDMI cables I can try though. Will report back ....

Cheers,
John.
Userlevel 1
Has anyone used this device to get an Nvidia Shield TV with DD5.1 working with a Playbase/Playbar?

My TV can pass through DD5.1, for Xbox One and STB box, but not for the Shield.

The Shield doesn't even offer 5.1 as an option in Netflix or Amazon Video. Apparently the Shield can only output DD+ through HDMI and not via Optical. Although that isn't strictly true because you can get DD5.1 on shield using Kodi.
Userlevel 5
Badge +12
Don't think the Edid Emulator will help with your Nvidia Shield as your TV seems happy to pass 5.1 through already.
Badge
I was also having an issue with not getting Dolby 5.1 with new hook up...only getting "stereo". After doing research I ended up going with this product below (see link) from Amazon that solved my problems. Once you connect, go to TV settings and select Dolby for the Audio option then once you check Sonos settings/about the Dolby 5.1 shows up...for optimal audio quality.

https://www.amazon.com/gp/product/B00SB2TQM2/ref=oh_aui_detailpage_o02_s00?ie=UTF8&psc=1
Userlevel 3
Badge +2
I use position "E", 1080p with 5.1 Dolby although it does pass through higher resolutions without issue.

Let me know if you need any help.


I picked up one to connect my PS4 slim (not Pro) to my LG SJ800V television. Set it to position E, PS4 set to Dolby Digital as is the TV but I am still only getting stereo. Am I missing something?
Has anyone used this device to get an Nvidia Shield TV with DD5.1 working with a Playbase/Playbar?

My TV can pass through DD5.1, for Xbox One and STB box, but not for the Shield.

The Shield doesn't even offer 5.1 as an option in Netflix or Amazon Video. Apparently the Shield can only output DD+ through HDMI and not via Optical. Although that isn't strictly true because you can get DD5.1 on shield using Kodi.


Have you been apply to get it working?
Userlevel 3
Badge +2
Has anyone used this device to get an Nvidia Shield TV with DD5.1 working with a Playbase/Playbar?

My TV can pass through DD5.1, for Xbox One and STB box, but not for the Shield.

The Shield doesn't even offer 5.1 as an option in Netflix or Amazon Video. Apparently the Shield can only output DD+ through HDMI and not via Optical. Although that isn't strictly true because you can get DD5.1 on shield using Kodi.


Have you been apply to get it working?


Didn’t get it to work but I have solved the problem: I am sending my Playbase back and as Sonos refuse to confirm if they will ever release a product with HDMI that will decode Atmos, DTS etc I will be buying a new Denon AV Receiver. I didn’t want to run a full 5.1 in the living room again but at least with an AV Receiver you know where you are. Also, consider this; I already have my old 5.1 speakers so for the same cost of a Playbase/Bar I can have the speaker cables professionally installed and it will still be cheaper.
Userlevel 2
Badge +3
Has anyone used this device to get an Nvidia Shield TV with DD5.1 working with a Playbase/Playbar?

My TV can pass through DD5.1, for Xbox One and STB box, but not for the Shield.

The Shield doesn't even offer 5.1 as an option in Netflix or Amazon Video. Apparently the Shield can only output DD+ through HDMI and not via Optical. Although that isn't strictly true because you can get DD5.1 on shield using Kodi.


Have you been apply to get it working?


Didn’t get it to work but I have solved the problem: I am sending my Playbase back and as Sonos refuse to confirm if they will ever release a product with HDMI that will decode Atmos, DTS etc I will be buying a new Denon AV Receiver. I didn’t want to run a full 5.1 in the living room again but at least with an AV Receiver you know where you are. Also, consider this; I already have my old 5.1 speakers so for the same cost of a Playbase/Bar I can have the speaker cables professionally installed and it will still be cheaper.


I have an almost new Denon Receiver I bought in January I am selling I even have a transferable 3 year square trade warranty I could transfer, you should send me a PM.
Badge +1
Tried one of these kwmobile edid on my Samsung TV, it actually reports a DD5.1 feed in the sound menu but it’s silent through my playbase, so annoying! Am I missing something obvious before I send the edid back?
Userlevel 7
Badge +20
Tried one of these kwmobile edid on my Samsung TV, it actually reports a DD5.1 feed in the sound menu but it’s silent through my playbase, so annoying! Am I missing something obvious before I send the edid back?

Please submit a diagnostic report while playing the TV when you don't hear any audio. Reply with the confirmation number and I'll take a look at the signal received.
I also tried one of these kwmobile edid on my TIVO to Samsung TV, it reports a DD5.1 feed in the sonos menu. The problem is when I change channels or pause the TIVO, I get a buzzing noise from the Beam until the sound resumes. Very loud and irritating. My question is, does the Beam send any signal to the Sonos sub when the input signal is stereo?
Userlevel 7
Badge +20
I also tried one of these kwmobile edid on my TIVO to Samsung TV, it reports a DD5.1 feed in the sonos menu. The problem is when I change channels or pause the TIVO, I get a buzzing noise from the Beam until the sound resumes. Very loud and irritating. My question is, does the Beam send any signal to the Sonos sub when the input signal is stereo?

Yes, the Beam should send a signal to the Sub in a stereo configuration. It would work just like it does for music with that signal.

Tried one of these kwmobile edid on my Samsung TV, it actually reports a DD5.1 feed in the sound menu but it’s silent through my playbase, so annoying! Am I missing something obvious before I send the edid back?Please submit a diagnostic report while playing the TV when you don't hear any audio. Reply with the confirmation number and I'll take a look at the signal received.

Hello Jeff,

I am running the same configuration and sonos beam is showing "silence". Diagnostics is 1948857933. I think it is maybe related to DD+ being sent instead of DD??

I am using a chromecast and forcing dolby using videostream, both the TV (dolby digital shows in audio config) and chromecast (shows that sorround sound is enabled when changing volume) are outputting dolby digital.

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings