Lost surround and sub ( after update ?)


Userlevel 3

Hi 

I don’t know if my issue is related to the 14.6 update but I noticed today that I had no sound from my surround (play 3) and my sub (Gen 2), only the Arc is working They are still present in the app under the my System view but now sound which every sources

When I reboot each of them, the sound comes back temporary, but when I switch to another source or audio format, thé Sound disappears again. Tried several times, same behavior

Thanks for your help

 

Corry P 3 months ago

Hello all,

Today, we released a software update (14.10) that includes targeted improvements on audio synchronization for home theater surrounds and Subs. If you have been experiencing delayed audio or dropouts to your surrounds or sub, this update should address your issue. We encourage you to update your system to the latest software release and to retest your system. 

If you continue to experience issues after this upgrade, please contact Sonos Support so we can help identify your specific issue and work to resolve it. 

Thank you for your continued engagement with the Sonos community. We understand any disruption to your experience is frustrating.  The Sonos team is committed to resolving any issue you experience so you can continue to enjoy your music and listening in the seamless manner you should expect.

View original

1604 replies

Userlevel 6
Badge +7

Did you just update the app or run the update on all the speakers?

What version is shown in about my system?

The Sonos Surrounds and Sub usually connect direct to the ‘bonded’ Sonos Arc over a 5Ghz ad-hoc wireless connection, rather than to your WiFi - So perhaps see if power-cycling the Arc resolves the issue, rather than the Surrounds/Sub and just ensure the WiFi adapter has not been disabled on your Arc - see this LINK.

 

Userlevel 3

Thanks for your answers

All my Sonos devices are in 14.6

I went to bed yesterday with no sub and surround, It’s working this morning whithout doing anything.

I’ ll see if it happens again, and check the arc wifi side

You didn't do anything but your router almost certainly refreshed IP address leases overnight.  Your router probably got a bit confused when rebooting speakers as part of the update

You can remove the risk of this happening again by reserving IP addresses for your Sonos speakers in your router's DHCP settings (if it lets you)

Userlevel 3

Thanks John for you input

I already have DHCP reservation for all Sonos Devices (and didn’t have any issue for years)

The issue occured again when trying to watch content on the Apple TV 

I tried to reboot the ARC only, and retrieved my surround and sub.

i noticed that ARP resolution from my mac returns the Arc mac adress for all reserved IP (same mac for Arc, surround and sub IPs) 

i’ll check IP and ARP next time it happens

Userlevel 3

Occured Again, and now, after rebooting the Arc, surround and sub worked for few seconds, and no sound again.

I ve checked ARP when rebooting the ARC :

  • ARC powered off : no ARP resolution (host down) for each devices
  • ARC booting : ARP is working (no sound) and each speaker has his own mac 
  • ARC booted : ARP is changed, all IPs are linked to the Arc Mac address

I think this is the normal behavior when creating a surround configuration.

I then removed surrounds and sub from the Home theatre configuration and add them again. it’s now working.

If the problem go back, I’ll contact the Sonos support

 

thanks again

Userlevel 6
Badge +6

Hi there I am also having this same issue since 14.6. Losing sub and surround audio even though in the app they show connected fine. Rebooting the arc is the only fix. I watch everything through Apple TV 

Userlevel 6
Badge +7

Is your arc wired to the router and is any of the sonos wired?

What is it showing in about my system wm:0 or 1?

 

Userlevel 6
Badge +6

My arc is wired to the router. No other speakers are wired. I tried unplugging to stop using sonosnet and it fixed it initially but eventually the issue returned 

 

I went back to sonosnet so everything is wm:0

Userlevel 6
Badge +7

Is wireless turned on the arc and is it showing wm:0 in about my system?

Userlevel 6
Badge +7

When it happens again run diagnostic and contact sonos support they will be able to see more information on your system 

Userlevel 6
Badge +6

happened again just now. I got an error when trying to submit diagnostics 

happens again just now. I got an error when trying to submit diagnostics 

Maybe try to get all your Sonos products back online and attempt to get the diagnostic report submitted, if possible …and note it’s reference number.

Then the best thing to do is to chat/contact Sonos Support Staff via this LINK and see if anything can be gleaned from your report. 

Certainly getting an error when attempting to submit indicates some sort of network issue. 

But it’s not required before you call Sonos. Helpful, to be sure, but not required. 

Userlevel 6
Badge +6

alright after some more troubleshooting I have some interesting findings.

my setup:

Sony A9G OLED with eARc

Exclusively watch everything through Apple TV 4K

Sonos Arc with 2 subs and play 1s as surrounds

 

I was able to consistently get the missing subs and surround error to occur whenever I changed from playing content in LPCM 5.1 to Stereo. Once that sequence of events happened I lost sub and surround audio until I power cycled the arc. When this happens in the app all the speakers still report as connected with no indication of a network issue. If i switch to different inputs or play music directly through the sonos app I still have no sub or surround audio 

 

A work around that I have found that has to do with my TV. In the audio output settings of my Sony A9G there are 2 settings of note:

eArc mode: auto or off

passthrough mode: auto or off

 

with eArc auto and passthrough off: I can consistently reproduce the error

with eArc off and passthrough mode auto: I never get LPCM but I do correctly getting dolby digital plus for 2.0 and 5.1 as well as dolby atmos. with this set up I have so far not been able to reproduce the issue. I actually prefer this because I don’t care for the drop in volume when using LPCM

with eArc auto and passthrough mode auto: I did not extensively test this as I prefer the other method but initially it seemed to not reproduce the error

 

additionally I confirmed that while the error was not occurring I was able to submit diagnostics fine, but while the issue was occurring I got a generic error when trying to submit diagnostics. This leads me to believe that whatever error is occurring with the surrounds and subs also causes an issue with submitting diagnostics

 

this was definitely never an issue before the 14.6 update. It seems like something changed that no longer plays well with the default state of the Sony tv passthrough audio mode being off while it worked fine before. (could be Sony’s fault I don’t really know)

 

@topilouf I am curious what kind of TV do you have? I hope my troubleshooting helps you out.

 

I’m happy with my work around but I’ll still be keeping an eye for any bug fixes

Userlevel 3

Since I removed and added surround and sub again to the config, no more issues (but it was yesterday)

I’ll make some tests again tonight, we’ll see if it happens again 

My TV is a Panasonic GZ1000, and I have although an HDFury Arcana (I’ll ask on their discord if the Arcana can be responsible)

 

Userlevel 6
Badge +6

just did some more testing and was able to reproduce the error on my Sony A9G with eARC on auto and passthrough on auto

 

I’ll be sticking with eARC off for now

Userlevel 4
Badge +2

Also experiencing this issue on 14.6.

 

Post-update I had to re-add all speakers for my surround setup, and now when I switch between devices I tend to lose my surrounds and sub (until I restart devices) - and lately now my volume’s are wonky.  Like my sub isn’t hitting as hard when it’s working - and surround’s aren’t as present.

Userlevel 6
Badge +6

just happened again even with eARC off. If any Sonos people are reading this I managed to submit diagnostics while it happened. #287608970

Userlevel 2
Badge +1

Same issues here, I’ve got Arc + play 3s + 2 subs - It’s happened 3x times in the last few days where the play 3s just are silent but in the app it shows that they are still connected.  Also, my subs still work.  The only way I can get them back is to either reset the router or unplug/plug the Arc.  The Arc is hardwired and provides SonosNet for the other pieces.  

One thing I’ve noticed is it seems to have happened when/after I play with my Xbox X which is on a different HDMI than my Apple TV. (LG C9)  Never had issues in the past before 14.6.  

Userlevel 2
Badge +1

Also, we’ve got a thread going on at the Sonos Reddit here as well: 

https://www.reddit.com/r/sonos/comments/ubqrdr/ever_since_146/

Userlevel 2
Badge

I am also seeing this issue since the 14.6 update.

 

Arc + 2 Play 3s + Sub connected to tv and a Move that is in the group that looses sound after a few minutes.  It comes back if I remove the Move and add it back to the group but it always goes away again. Sometimes it will get sound for a few seconds but it is completely out of sync. The other speakers may be loosing sound but they are less noticeable since they are surround and the Move is off by itself.

 

My tv is a Samsung Q90R and my Sonos is not connected by ethernet.

Userlevel 6
Badge +6

Yesterday I removed my surrounds and subs from the system and re-added them. So far the issue hasn’t happened again. Will update again after some more time 

Userlevel 6
Badge +6

and it just happened again ahaha 

Sure sounds like a potential duplicate IP address issue to me. Or possibly simple variable wifi interference, particularly in the 5GHz range, although it could be from somewhere else. 

 

At the least, I’d unplug all Sonos devices from power, and reboot your router. Once the router comes back up, plug back in all Sonos devices, which will force them to both reload their own firmware, but request new IP addresses from your refreshed router. And then I’d be reading the linked FAQ. 

If it continues, submit a diagnostic to Sonos, who will be able to look at the hard data in the diagnostic, something that us denizens of this board don’t have access to. 

Reply