Lip Sync Problems

  • 20 February 2017
  • 30 replies
  • 7674 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

30 replies

UE40KU6400. Nothing special about the settings, other than of course specifying that the output audio format should be 'Dolby Digital'. HDMI audio format already defaults to 'Bitstream'.
Userlevel 2
Badge
In my case (since I have a Samsung TV) using the Monoprice audio extractor you mentioned would only give me stereo audio not Dolby 5.1 but if stereo is OK that should work fine. With your Sony set for Dolby passthrough (which Samsung doesn't support) you should get Dolby 5.1 from the Monoprice I would think.


I think it must be but I'm not sure how to verify that because I don't have surround speakers yet, they are on the way. The 5.1 light on the monoprice switch is on, if that means anything.

When you say Sony set for "Dolby pass through", I'm not sure how to do that either.


But unless your TV's video delay "happens" to be exactly your Sonos delay it seems odd that "alone" solved your lip-sync problems. Usually the TV's video delay ( say 70 or 80 ms) is too much and will need some additional audio delay applied to get it perfect. For example if it's 80 ms and your Sonos is 30 ms audio delay it would take 50 ms of audio delay added back in to get it perfect.


I am using the sonos delay adjuster to add some delay back to line up lip sync. Seems to look right around position 4 out of 6 on the slider. Not sure how many ms that is adding back. If I turn the tv speakers on at the same time, the sound matches the tv speakers the best at position 5 actually, in terms of lined up audio, but the visual lip sync is better at position 4.

This leads me to the following conclusion:

The Sony is adding just a hair too much delay to the audio inside the tv. The difference between position 4 and position 5 on the slider, however that much is. I never noticed it when I used the tv speakers. Without the switch, the audio from tv optical must have at least this much padded audio delay also, which is then delayed even more by the sonos wireless latency. The combined delay is long enough to notice and be annoyed.

With the switch I can use the sonos to pad the audio delay and be where it needs to be. It works but I wish the Sony tv had a way to reduce the audio padding there.


But according to the Stanford study most people don't "consciously" notice 42 ms video delay so maybe it reduced it below that threshold. If you focus "deliberately" on the lips is it really perfect?


what I read is that most people can tolerate even more then 42ms of audio delay, until they notice it, then once they notice it their tolerance drops way down. I suspect Sony was erring to the slightly long delay side on how much they pad the audio delay figuring exactly this. Possibly better for audio to be slightly late then to be slightly early, if you know what I mean. In any case I didn't notice lip sync problems from the tv speakers before getting the sonos, but now that I'm paying attention I did become less tolerant of the tv speakers which have slight delay, but its tight enough most would not notice and I probably could readjust my tolerance over time. However when that delay is added to sonos wireless latency, then it became immediately noticeable and annoying to me, nobody pointed it out to me, I saw it straight away and could not tolerate it, however much delay that was.

I think with the switch the lip sync is better then the tv speakers, not perfect but pretty darn good and when I'm not looking for it, it is pretty spot on, within the tolerance.

I was at my buddy's house, his Samsung and non wireless soundbar had horrible lip sync in comparison and he was oblivious.
My system suffers from a frustrating audio delay as well. The most frustrating aspect is that my STB, display, and Sonos each provide options to add more audio delay, but what I actually need is audio acceleration OR video delay.

My system includes a Vizio E-70 with a Playbar attached via optical cable. The playbar is connected to wired Ethernet, and my 5.1 setup includes Play 1’s with a sub, all wireless. The delay is noticeable on all inputs including the U-Verse DVR STB, Blu-ray, and SmartCast sources like Netflix.

Does anyone know of a way to add video delay to an input, or how to accelerate audio (not to delay it) at the soundbar?
Userlevel 2
Badge
If your tv itself has an option to adjust audio delay to a lower value then use that. If not then get an hdmi switch that has optical audio breakout such as the monoprice, and fork off the audio from the hdmi before it hits the tv. The tv adds video delay so then you will be able to use Sonos lip sync adjustment to add delay to the audio and bring them back in sync.
Userlevel 6
Badge +13
I'm quite sensitive to lip sync issues, my 7 year old Samsung works fine sync wise through all sources with my Playbar (only catch is having to use HDMI EDID emulators to pass 5.1 through TOSlink).

Surround and Sub keep up well, never tried Grouping another speaker but at 70ms it would deffinitely be an audible echo for me.