Question

LG Oled C9 magic remote and volume control

  • 8 August 2019
  • 10 replies
  • 4415 views

Badge
Hey everyone,

I've just purchased a gleaming new 2019 LG OLED 65" C9 TV and a Playbase, Sub and two Play1's. All went to plan until I tried to turn the volume up/down which doesn't work with the magic remote (given it doesn't have IR functionality)

My investigations on the support forum gives me instructions for the C8 (press Home, go to Device Connector). However the Device Connector isn't an option on the Home menu for the C9 so I'm stumped. Can someone please help out here as I'm so close, yet so far away from having the perfect cinema experience!

Thanks all

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

Userlevel 6
Badge +14
Since you have a brand new TV, you probably use the HDMI ARC port for your Beam. If that is the case there’s usually no need to use the remote to directly control the Beam. HDMI CEC (I believe LG calls it Simplink) takes care of this, by letting the TV relay the commands it receives from the remote to the Beam. Is CEC turned on?
Badge
Morning 106rallye,

Thanks for the note, but I'm still a little confused.

Firstly I'm using a Playbase, not a Beam, secondly the only connector between the TV and the Playbase is the Optical Audio cable rather than an HDMI ARC cable. And finally Im not sure what the CEC is. Any chance you can help further?
Userlevel 5
Badge +13
Your best bet is to reach out to LG to see if that remote can send an IR signal.

If so, you'll need that configured first. Then you can set up your Playbase with the remote.

That or just get a universal IR remote.
Userlevel 6
Badge +14
@Morsey Sorry, I misread your post. A Playbase does not have HDMI ARC - just optical. Please disregard my answer.
I purchased a 65in C9 yesterday, aware of the volume control issue and expecting to use my Harmony etc etc. Just followed the Device Connector/Bluetooth/Soundbar menus, nominated Optical as I have a Playbar, nominated Sonos in the manufacturer's menu plus a couple of clicks and volume control working perfectly. Was on OS 3.5 but since updated to 3.6.

I can see the IR light on the Playbar flashing during volume adjustment so assume that IR has been turned on in the Magic Remote somehow.

I have the same frustration. Just purchased a new 55 in C9 that came with an updated version of the Magic remote (not like the one referred to on other similar posts). The C8 fix seemed to be to ‘trick’ the TV by saying you have a PHILIPS soundbar and then selecting ‘Remote 4’. However, for the C9 interface, there is no option for selecting remote type, and in fact, there is an option for Sonos. I’ve tried both setting up by selecting Sonos and selecting Philips. Neither option allows me to control the Sonos bar via Magic remote. Help!

My understanding of this issue is the key is getting the “magic remote” not to be as “Magic” by forcing it to use IR, rather than Bluetooth or WiFi. Does LG have a customer assistance number that you could contact, if such information is not in the manual? Or, if no C9 owner replies here, you might contact Sonos Support directly to discuss it.

I usually suggest the phone folks, they have more tools available because they're on the phone with you, but they are only available Monday through Friday during business hours. Both the Twitter and Facebook support folks are available 24/7.

I got my LG C9 setup and the Magic Remote to work. The menue changes since the C8 model, but once you found it it’s the same process as for the C8 ( e.g. https://www.youtube.com/watch?v=0qLeA5ShPFI )

 

When you hit the Settings Button you get the Sewttings icons at the lift side of the screen. The purple one at the bottom ( it says something like Network Connections ). Open that menue and you see the Device Connector option. Then it’s like in the video or any other guide for the C8.

Yes it's solved. No need to choose Philips like in the video. Simply search for Sonos as it's not in the list but it will be found!!! You're done without any setting in the sonsos app :). Enjoy and Slainte. The WhiskyPapa

 

Thanks for this.   The trick for me was finding the device connector menu.  I did not think to look for it under network.