How to Connect LG UltraHD UB980 series remote to Playbar

  • 20 August 2014
  • 8 replies
  • 6946 views

I have a new LG 4K TV with the magic remote. Can you please explain how to get the magic remote to operate the playbar and sub volumes and mute etc. Sonos is not even listed as a manufacturer in the LG's list of external devices (& believe me they appear to list everyone else). What's is going on here Sonos? This is really annoying and frustrating. And please don't even think about suggesting a Universal remote as an option.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Userlevel 1
I have the same magic remote. Doesn't work, different technology (radio instead of IR?). I was given a standard LG remote from my LG/SONOS supplier. I'm getting used to it but there are a lot of remotes on the table, and I've tried and rejected Harmony remotes before...
Given there is an optical cable connection to the TV the IR issue should be overcomable. It's not reasonable to spend circa $7,000 on the setup using two supposedly very reputable suppliers and then not have their remotes work together.
Userlevel 7
Badge +26
The Optical connection between the TV and the PLAYBAR is only for audio signals, there isn't any other data transmission taking place. Depending on the version of your LG Magic Remote, you can try these directions on our User Forums.

The PLAYBAR has an IR receiver for remote control so your remote needs to be able to send those commands or have the Sonos UPnP commands built in sent wirelessly through the network. 
Here is the solution (as posted here: https://ask.sonos.com/sonos/topics/connect_lg_remote_with_playbar):

Note: this works for my TV model above, the onscreen menu is slightly different but workable and you need to get the hang of it and then do it quickly or the on screen times out and goes back to the topmenu, You'll get what I mean when you follow the steps below and try to get through to the mute step. However after much screwing around I now have a playbar and sub with a Vol+ Vol - AND Mute working from LG Magic Remote.

nb: LG advised that the Magic Remote I have does have an IR sender in it as well as the RF. I imagine with RF alone and Ryans comment above there is no solution. Not sure how many models shipped with a Magic Remote with no IR sender before LG realised what this would mean for the end user.

Ok I resolved it - here is how:
1) Go to the LG "Universal Control" and add a Philips sound bar
2) Once done exit the setup and switch to your normal TV input
3) Bring up the LG on-screen remote by pressing the "123/QMenu" button
4) Choose the left/right arrows on top of the on-screen remote until a grey "S.Bar" button appears in the top row
5) Choose the "S.Bar" button which changes the on-screen remote to shrink, show a green "Phillips" button and more importantly the Vol+ and Vol- buttons
6) Launch the Sonos contoller, go into the remote control setup and choose "Replace Remote"
7) When the Sonos controller asks for the respective Vol+ / Vol- buttons use the ones off the on-screen remote from step 5
😎 The mute button was not available on the on-screen remote so to complete the Sonos remote setup go back to step one and go through the same sound bar setup again which will give you the mute button on-screen as some of the button to test

There might be an easier way of doing this but the above worked for me and hopefully for some other people as well...
Userlevel 1
Here is the solution (as posted here: https://ask.sonos.com/sonos/topics/connect_lg_remote_with_playbar):

Note: this works for my TV model above, the onscreen menu is slightly different but workable and you need to get the hang of it and then do it quickly or the on screen times out and goes back to the topmenu, You'll get what I mean when you follow the steps below and try to get through to the mute step. However after much screwing around I now have a playbar and sub with a Vol+ Vol - AND Mute working from LG Magic Remote.

nb: LG advised that the Magic Remote I have does have an IR sender in it as well as the RF. I imagine with RF alone and Ryans comment above there is no solution. Not sure how many models shipped with a Magic Remote with no IR sender before LG realised what this would mean for the end user.

Ok I resolved it - here is how:
1) Go to the LG "Universal Control" and add a Philips sound bar
2) Once done exit the setup and switch to your normal TV input
3) Bring up the LG on-screen remote by pressing the "123/QMenu" button
4) Choose the left/right arrows on top of the on-screen remote until a grey "S.Bar" button appears in the top row
5) Choose the "S.Bar" button which changes the on-screen remote to shrink, show a green "Phillips" button and more importantly the Vol+ and Vol- buttons
6) Launch the Sonos contoller, go into the remote control setup and choose "Replace Remote"
7) When the Sonos controller asks for the respective Vol+ / Vol- buttons use the ones off the on-screen remote from step 5
😎 The mute button was not available on the on-screen remote so to complete the Sonos remote setup go back to step one and go through the same sound bar setup again which will give you the mute button on-screen as some of the button to test

There might be an easier way of doing this but the above worked for me and hopefully for some other people as well...

Amazing! Thanks a lot!!! I've been using the basic remote to adjust the volume now for over a year with my LG 47LA860W. And now this! One huge remote less! 🙂
This reply was created from a merged topic originally titled LG Smart TV Remote no longer adjust playbar volume??. I have an LG Smart TV and until last week i was able to adjust the volume of my playbar with the TV's remote and now it no longer works. I have tried to recalibrate it, turn the TV off, reset everything and it still fails to work. 
Why would it work last week and now no longer?

I am running apple TV also through the HDMI and i'm sure it doesn't interfere because it was all working last week! 

Can someone please give me a suitable solution to fix it?

Cheers.
If you have a 2016 LG OLED display E6P (and probably G6P etc) the correct setting for playbar is PHILLIPS - Controller #4. Works like a charm.
Don't have the Universal Control menu on my end here - 86UK70 😞

Anyone had this issue and found a solution ?

Thanks