How do I 'un-bond' surround speakers connected to a Connect:Amp

  • 19 October 2016
  • 9 replies

Userlevel 2
I've not been able to get my surround speakers to work since I bonded them to my Playbar (they are connected to a Connect:Amp). They worked fine as a separate pair prior to being bonded. I've set them to 'full' rather than 'ambient' and confirmed that the audio stream is DD5.1 but no luck.

I'd like to un-bond and re-bond them but I can't find the option to do this on the PC or iOS Sonos controllers.

I've read there should be a "Remove Surround Speakers" option in the "Room Settings" section but it's not there! Did this functionality change in a recent upgrade?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies

Userlevel 2
Note that I have an ASUS RT-N66U router. It is possible that this has something to do with the problems I am encountering,..
You could wire the connect:amp directly to the Playbar temporarily, bypassing the router. You also need to check you're actually feeding the Playbar 5.1 and not stereo.
Userlevel 2
Great idea. I tried it and the surrounds work perfectly when connected directly to the Playbar - so it looks like my ASUS router is the problem.

I could also bypass the router if the Playbar could bond with the surrounds on the 5Ghz frequency but I'm pretty sure this is only possible when using Play 1s or Play 3 as the surround speakers, ie, the Connect:Amp is not 5GHz capable.
Correct, the C:A doesn't contain a 5ghz radio.
ASUS RT routers with outdated firmware are known to have problems with multiply wired Sonos units. They apparently block STP traffic. The solution is to update the firmware.

Wiring directly between the PLAYBAR and CONNECT:AMP is quite permissible, so long as some other Sonos component is wired back to the router.

I've not had cause to check, but unbonding the C:A for surrounds should surely be achievable via http://######:1400/wiredsat.htm. In any event a factory reset of the C:A should also work.
Userlevel 2
My router running the latest firmware.

I've been troubleshooting all evening and did get everything working briefly but don't seem to be able to repeat it.

I think the easiest solution will be wire the Playbar back to the router (as the sole wired Sonos device) and then connect the C:A directly to the Playbar rather than via the network.
In order to use the CONNECT:AMP as surround speakers with the PLAYBAR you need to have it either wired to the network (with the PLAYBAR also wired to the network) or directly wired to the PLAYBAR. This is because the CONNECT:AMP doesn't have 5GHz and isn't capable of keeping up to speed with the PLAYBAR's audio unless wired.

If wiring both the PLAYBAR and CONNECT:AMP is the path you need to take, let us know if you have any trouble with that router and multiple wired Sonos players. As ratty suggested, there have been some known issues with the RT series.

For anyone looking for directions to un-bond a CONNECT:AMP, here you go, just expanding on ratty’s notes above:

Removing the CONNECT:AMP as bonded surrounds is slightly different than how you would normally remove Sonos players.

Locate the IP address for your PLAYBAR - not the CONNECT:AMP.

On Mac: Sonos > About My Sonos System
On PC: Help > About My Sonos System
On iOS or Android: Sonos music menu > Settings > About My Sonos System

Open a web browser on your computer or mobile device, (e.g., Safari, Firefox, Google Chrome, Internet Explorer).

In the address bar, type in the following URL, replacing ####### with the IP address of your PLAYBAR: http://address.of.the.playbar:1400/wiredsat.htm).

Follow the on-screen prompts to remove the CONNECT:AMP surround setup.

More info can be found here.

If you encounter any issues, feel free to post a diagnostic number, steps here, and I'll be happy to have a look for you.
Userlevel 2
Thanks Ratty and Nico R. The Asus RT is clearly part of the problem. I'm going to spend a few more hours trying to get it to work over the weekend.If i can't get it working I'll post a diagnostic number.
Userlevel 2
I finally got this all working. I unplugged everything from the network. Reset the router. Turned on the the Playbar (wired to the switch). Turned on the C:A (wired to the switch). Turned on my Samsung smart TV and tested some 5.1 material (it worked!). Turned on all of my other Sonos devices (wireless). Reconnected the rest of the network. All good.