Question

Brand New Arc Suround System bricked


Brand New Sonos Arc, Sub3 and Era300 x2 System.

The Arc and Sub will not update no matter what I try, the firmware update always fails.

Info on the Arc:
Sonos OS: S2
Version: 14.2 (build 67127109manufacturing)
Hardware Version: 1.27.1.12-4.2
Series ID: A103
IP Address: 192.168.86.249 (Wired)
Audio In: 
WM: 0


I have spent 3 days, several hours with chat support, + 5 hours with Sonos phone support.

I have tried everything I could find online, including recent things from Reddit or Sonos forum, including:

  • Make a new Sonos account with an email address I have not used.
  • Countless variations on hard reset and reboots on Wifi, the Arc, only 2.4ghz, wired etc.
  • Attempting the firmware update on other devices, so far 5 different android devices and the Windows app (don't have access to IOS device).
  • Resetting the devices and adding / updating one device at a time.
  • Making sure I have the latest Sonos app and doing everything over again, currently v 80.02.07 and Windows app v16.2.

    The Era 300s did update just fine when I tried those individually.
    Arc and Sub returns error 30 when attempting on the windows app.
    And Arc returns error 10xx variations depending on the method.

This was my dream system.
I'm giving Sonos a week to fix the app, if not I'm returning everything and never going Sonos again.

Imagine if you bought a car, and it didn't run right away because the manufacturer decided to redesign the key after the fact, and the new key they sent you doesn't fit. Plus, they took the old key, so now you're stuck with a brand-new car sitting in your driveway, unable to drive it for days, weeks, or even months. It's just unacceptable.


10 replies

Userlevel 7
Badge +20

Hi

Your hardware version is newer than mine (Mine is 1.27.1.8-2.2) My Arc firmware version is 79.1-53290 which is the same as my Era 300 surrounds.  Your app version is the same as mine.

I don’t know if you’ve followed the steps in my article below but worth a try:

Please note, looking at your router settings will NOT show duplicate IP Addresses.

Thanks, but I have eliminated any possibility of error on my side/network.
 

I have even tried hooking the Arc up to the main router and giving it its own dedicated 2.4ghz network on the off chance that it didn't like being hardwired.

I can monitor the network activity, it has actvity, it has its own ip, it is uploading/downloading.
I have even tried to forward all the ports that sonos update servers are using.
The device just refuses to update.

The Sub3 also has problems, but I have just disconnected that and the other devices now until the Arc works.

Cant get a Sonos response to this?

Userlevel 7
Badge +23

Cant get a Sonos response to this?

No, the terrible new app has buried their Support teams for the last month and its not getting any better.

Cant get a Sonos response to this?

No, the terrible new app has buried their Support teams for the last month and its not getting any better.

Surely has to be some priority in the support.
“The feature I liked in the old app is gone” is less important than “My entire system is bricked”

I bought the same system yesterday and have the same problem as you. The Arc works together with my TV, but it does not appear in the app. The Sub and Era300 appear in the app but are useless unless the Arc is not registered in the app. Hopeless. I tried all the suggestions on how to fix it but no luck. Wonder if I am just going to return all of it if this is a normal problem… 

I bought the same system yesterday and have the same problem as you. The Arc works together with my TV, but it does not appear in the app. The Sub and Era300 appear in the app but are useless unless the Arc is not registered in the app. Hopeless. I tried all the suggestions on how to fix it but no luck. Wonder if I am just going to return all of it if this is a normal problem… 

If you are in Japan then the only way to solve it is to enable a VPN to the USA in your router then update.

The solution was discovered by the reddit community.

Sonos did not help AT ALL.

I bought the same system yesterday and have the same problem as you. The Arc works together with my TV, but it does not appear in the app. The Sub and Era300 appear in the app but are useless unless the Arc is not registered in the app. Hopeless. I tried all the suggestions on how to fix it but no luck. Wonder if I am just going to return all of it if this is a normal problem… 

If you are in Japan then the only way to solve it is to enable a VPN to the USA in your router then update.

The solution was discovered by the reddit community.

Sonos did not help AT ALL.

I am in Norway, but guess the problem is the same here.. Have read about the same problems the last days, but I thought it would be taken care of by Sonos. 20% off was a good deal so I went for it. Luckily there is a return policy if they do not fix the problem asap

Userlevel 1

I cannot get the VPN method to work, even if I connect them to the network, the app seems to not find them.  I guess I’m stuck waiting for an app update.  So ridiculous

I am in Japan and set up my router to use US VPN (with nordvpn) finally worked for me to update.

First time I have an issue with Sonos but support is terrible..

Reply