Beam timeout is infuriating

  • 13 May 2022
  • 6 replies
  • 110 views

I have my Beam connected to my home entertainment center, which happens to be powered by a PC. It works great except that if the computer is silent for 10 minutes, Sonos switches off of TV input. Switching it back manually is frankly a PitA - I set it to TV input, and I want it to stay that way until I change it.

I know many use the default “autoplay” setting so if TV sound is detected it switches to TV input, but that means anytime anyone messages me my music cuts out if I’m playing a song from the app or by voice. Plus there’s a delay while it switches back, which an obnoxious and leads to missed messages. Again, I had Sonos stream music, and I want it to stay that way until I change it.

There were several requests some years ago about this (eg https://en.community.sonos.com/home-theater-228993/playbar-tv-source-timeout-6734339), but at the time the answer seemed to be just “it’s fixed to timeout to 10 minutes and you can’t change it.” Is there some reason we still can’t override this infuriating behavior? Or any clever work arounds?


6 replies

Userlevel 7

Say “Alexa, set mode to TV.”

Or when Sonos Voice Control is available in June, say “Hey Sonos, switch to TV mode.”

https://support.sonos.com/s/article/5108

There’s a timeout to prevent the amplifiers in the Beam (and home theatre satellites if any) remaining powered and chewing unnecessary amounts of energy. 

Say “Alexa, set mode to TV.”

Or when Sonos Voice Control is available in June, say “Hey Sonos, switch to TV mode.”

https://support.sonos.com/s/article/5108

Right, I can yell at my speakers to turn on every 10 minutes… I just want them to stay on TV input until I turn them off. 

(As the speakers for my PC, sounds can be infrequent. But also don’t want to miss email/message chimes.)

 

There’s a timeout to prevent the amplifiers in the Beam (and home theatre satellites if any) remaining powered and chewing unnecessary amounts of energy. 

Sure, I understand why a timeout might be the default behavior. 10 minutes should be able to be changed though (you shouldn’t have to turn your speakers on if you pause a movie for a snack, and 10 minutes is really short) and the feature should be able to be turned off.

It’s more frustrating because when they’re acting as PC speakers the expectations are different. But even for standard home theater, folks have been asking for a change for years now…. Autoplay mode isn’t for everyone.

Userlevel 7

Say “Alexa, set mode to TV.”

Or when Sonos Voice Control is available in June, say “Hey Sonos, switch to TV mode.”

https://support.sonos.com/s/article/5108

Right, I can yell at my speakers to turn on every 10 minutes… I just want them to stay on TV input until I turn them off. 

You asked for a “workaround”. That’s it.

 

you shouldn’t have to turn your speakers on if you pause a movie for a snack, and 10 minutes is really short

You don’t have to manually turn your speakers on after pausing a movie for 10 minutes if TV Autoplay is enabled.

Say “Alexa, set mode to TV.”

Or when Sonos Voice Control is available in June, say “Hey Sonos, switch to TV mode.”

https://support.sonos.com/s/article/5108

Right, I can yell at my speakers to turn on every 10 minutes… I just want them to stay on TV input until I turn them off. 

You asked for a “workaround”. That’s it.

 

you shouldn’t have to turn your speakers on if you pause a movie for a snack, and 10 minutes is really short

You don’t have to manually turn your speakers on after pausing a movie for 10 minutes if TV Autoplay is enabled.

That’s not a workaround. I said I needed a way to keep it on TV input or change the annoying time out, that changing it back each time was a pain. Listing one of the ways to change it back each time isn’t a fix or workaround, it’s what I said I was trying to avoid having to do.

Like I’m on the verge of writing an app that makes an inaudible pop every few minutes just to keep this expensive speaker system from continuously turning itself off. That seems rather silly.

I get that autoplay works for some. I’ve said why it doesn’t for me. Other folks have made similar requests to turn off the timeout in the past. Not sure why you’re doubling down on answers I said don’t solve my problem - if you don’t have a fix, that’s fine.

A fix could also be an addition of “TV Autoplay… unless Sonos is currently playing audio.” That would be fine too. I imagine some others don’t want the music to stop just because someone pushes a button on the TV.

Being able to change it from 10 minutes to an hour or two would also work great.

I just don’t want my music to stop every time my computer beeps (autoplay). Or have to re-enable TV input 30x a day (10 minute timeout w/o autoplay).

Reply