Beam overrides speaker settings on Samsung TV

  • 28 November 2018
  • 5 replies

I have Beam and 2 x Sono Ones connected to my TV. However my wife often does not want to hear what's on the TV, so I use bluetooth headphones. In my Samsung TV speaker settings you can choose 'Receiver' ie Sonos or Bluetooth. When I choose Bluetooth the sound comes to the headset for about 3 seconds - the Sonos sound goes off, then the headset is cut out and sound reverts to Sonos. Why? My previous sound bar (a Bose) didn't do this. Currently I have to disconnect the HDMI (ARC) from the TV to allow the bluetooth to work uninterrupted. Any ideas how to solve this problem please?

5 replies

I have the same problem. Any solutions out there, other than unplugging the beam?
I was having the exact same problem with my LG C8. Looks like when the Beam is connected to the TV using ARC it always requests the sound from the TV and hence the TV defaults to it. The only way to stop it without unplugging the Beam is to go to your TV options and turn HDMI Simplink/Anynet/CEC Off. When you switch back to ARC it should automatically Turn the setting on, else the other way round, you might need to manually turn it on and it will switch to ARC automatically
Same issue here with a Samsung TV and the Sonos AMP (2019). I'm pretty sure its a Samsung issue with "auto-switch". Samsung seems non-responsive to the issue.

Here is an old post about it...
I just read up a bit more... Samsung made a little trick to fix it - it's not perfect, but it works okay.
1. disable Anynet+
2. switch audio output to optical out - this with play on your Beam
3. switch to tv-speakers - will be from your TV - without auto-switching...
Userlevel 7
Badge +21
It sounds like the verge article is talking about a slightly different issue. And I don't think the bluetooth headphone issue is limited to Samsung TVs.