Beam IR sensor stopped recognizing remotes

I have a beam connected to optical on TV. Remote was paired and everything was working fine. One day remote volume control stopped working. I tried to set up the remote again but the IR sensor did not recognize when buttons were pushed. Tried a different remote and it didn't recognize that either. I can still control volume with the app but IR sensor does not seem to receive any signal. Any suggestions?

Best answer by Airgetlam 4 February 2020, 03:30

View original

95 replies

Try replacing the batteries in your remote. If it isn’t normally an IR remote, but a Bluetooth one, make sure to reset it to send IR, it’s possible a firmware update to the TV turned that option off. Double check to be sure the line of sight between the remote and the Beam’s IR sensor isn’t obstructed, or the sensor isn’t dirty.
Oh, and try a simple power cycle on the Beam itself, to force a reboot of the device.
Any luck. I just bought a beam this weekend and I’m having a similar problem. Worked previously but I had to unplug and move it. Since restarting, no remote control via ir.
Customer reports the same problem with the beam. Appears to work for about 8 to 12 hours then is unresponsive to the comcast remote. No volume change and no lights. Otherwise the system works. IR receiver seems to be locked up and power cycling the beam resolves the issue for 8 to 12 hours before repeats. We replaced the Beam and the problem persists.
Yeh that’s what I’m finding too. I’ll try it again tonight now that I’ve got it in a good spot and wasn’t planning on moving it anymore.

I really like the beam (and sonos) so this is a bit frustrating.
I have done 8 installs with this product and prefer the Sonos Bar. This one is troublesome and I got a response that they haven't had reports of this with any other Beams. So It would be advisable to collect as much information about the system and beam location and submit it for a ticket for them to have visibility to this issue. I am testing the first unit and trying to replicate it and even have moved the beam to the exterior window to see if it will lock up.
I can confirm the same issue of loss of IR Control and that a hard reboot of the beam returns the IR control to normal. Sounds like firmware bugs or some other issue...

please us give us a fix!

Confirming the same issue as in this thread.

Beam all of a sudden lost IR response. Unable to do a remove control setup.

Need to hard reset the Beam but unplugging it, appears to work for a bit but then loses connection again.

This is not a remote battery or tv firmware issue. It’s the Beam that’s causing the problem.

Sorry, I meant it to be a Beam Firmware issue - not something els like the remote. 

Here’s an interesting update to something I noticed last night: 

  1. Like others here, when I do a hard reboot (power out) i regain IR control, only to lose it again in a day or so
  2. Yesterday morning, i realized I had lost control, but didnt have the time to get behind the unit and pull the plug….
  3. Yesterday my wife started playing music from the Sonos app from our Kitchen Play5 and also to the Beam in the bedroom while she was doing house chores. (grouped)
  4. later that night, forgetting that I had lost IR control and failed to reboot (in 2 above) I was wacthing a show and went to control the volume - and it worked! I was suprised when it occued to me I hadnt rebooted it. 

So what does this tell me? This probably has something to do with bugs in the various modes of the Beam. What I do every day is: start a playlist from SXM as an Alarm,  talk to Alexa in the morning to hear weather, call out voice command for playing streams various source ( generally Amazon Music and SXM streams) while I’m getting ready for work, etc.. Then later that evening when watching a show is when I notice loss of IR control. 

So I’m going to try and recreate this flow:

 1) doing what I normally do in the morning and see if I later have loss of IR control. 2) spawn music from another play to also play in the bedrom. 3) see if regain IR control. 

Wondering if somehow voice control with Alexa is getting into the mix here… 

Userlevel 1


I am having the same problem where the Beam works fine and then stops responding to the volume buttons on my remote.  If I reboot the Beam then it will work again for a couple of days and then stop.  This is very frustrating.  My remote is new, my batteries are new, the sensor is not blocked so it must be a Sonos issue as rebooting resolves the problem for awhile.  Sonos, Please help as I have many of your products and this is the first one that has not functioned properly.

You may want to contact Sonos Support directly to discuss it.

I suggest the phone folks, they have more tools available because they're on the phone with you, but they are only available Monday through Friday during business hours. Both the Twitter and Facebook support folks are available 24/7.

It appears to be the last Sonos Beam update that is causing the issue. Hopefully they put out a hotfix update but likely we won’t see it until next year.


Very disappointing. Device is otherwise great.

Is that what Support said to you? Most interesting.

Here’s a little to add, which i have figured out by trial and error. This problem definitely seems like a weird software/firmware bug. 

1) Starting with music, either by Alexa or by the app, volume control works fine. 

2) switch to TV by whatever method, in my case I just start Apple TV and the audio is replaced by the TV source sounds. Volume won’t work from the same remote used in step 1 above. 

3) out of frustration to lower the volume because the TV show is too loud, start the Sonos app and lower the volume using the app. 

4) forget the remote isn’t supposed to work and try to change volume with the remote — and be super surprised that the IR remote now works! 

so bottom line, if you use the app to change volume when the IR control isn’t working, the IR will start working. YMMV, but this consistently works for me. 

Using the iOS app works fine to adjust volume. It’s just annoying you have to have your phone with you to do so. The app also appears to be the only way to turn on night mode.

Using the iOS app does not make the IR start working for me unfortunately.

Only way to get IR to start working again is a hard reset; unplug + plug back in.

I also have this problem. I’ve never been able to get my Beam to acknowledge my TV remote, and now it won’t register any button presses from my Apple TV remote as well. I know the IR on the Apple TV remote is working, because it turns up the volume on my TV without issue.

This is definitely a Sonos issue and only Sonos will be able to fix it with an update.   Judging by this thread along with a dozen or so other forums I have come across regarding this issue, this is by no means isolated or rare.   I love my Sonos system! I hope they move quickly on this or the Beam’s reputation may be put on the line

Just wanted to report I have the same issue, only a hard reboot fixes.


very frustrating 

I had the same issue. Called support about a half dozen times. The sent me a new beam and the new one has the same problem. I mention this threat to the guy at support and he said he had never heard anything like this. I hope the help us soon. Is this only a problem for those connected with the optical port or is the hdmi connection also a problem?

I have two beams, both connected via optical but only one has the problem, replacement made no difference.


One thing I may do at some point is switch them over see if the problem follows the device

Please let us know. I am going to try to move mine to a different tv and see what happens.

Userlevel 1

I'm not new to sonos, but am new to beam. Mine has failed to recognize my samsung IR remote since day 1. Like others I've tried about every remote in the house, it just wont recognize any ir signal. I'm ok with it but nobody else around my house is, especially my wife. Probably end up returning it to costco

There are some cases where an IR remote sensor gets overwhelmed by the light coming from the TV. You may want to try putting a 3x5 card tenting the location of the sensor, to ‘shade’ it from the TV’s light, and see if that makes a difference. If it does, then you can experiment further to find a solution. If it doesn’t work, then you’ve at least tried. 

I’m having the same issue. Resetting the Beam fixes it. It’s not batteries, and it’s not about the sensor getting flooded. There are a few threads on the forums about the same issue. I hope Sonos takes note as I’m also thinking of sending this back, like many others.

Userlevel 4
Badge +11

Hi @jamesandjaque ,

For testing purposes, can you try using another TV remote to your Beam temporarily? If the issue occurs using another TV remote, try factory resetting the Beam to default and set it up again as new product. Let me know if the issue still continues after trying these steps.