Amp wont register on my account

Ive just installed a new Sonos Amp. Ive used the Sonos App on IOS to install it and all works ok. Then the app trys to register the amp on my Sonos account and I get an error saying cant connect try later.


I have checked my Sonos account and logged in and updated my address and password all seems ok.


Any ideas please. Thanks 


Best answer by Imrelehem 10 May 2024, 05:56

View original

7 replies

Sorry I meant to say I have tried to add my amp via wifi and ethernet and I have reset the amp each time. At the moment the amp is showing on my system in the app but is not registered

I have same issue. I bought it used today and now I’m worried that it might be stolen and in black list or something- so that is why it would not register. Or I’m just overthinking it. If you find any solution please let me know here aswell. And vise versa if I find a solution. I will contact sonos aswell


I have this same issue. Just bought the new connect amp through the upgrade process because the old original connect amp did not register either.  So I thought the new amp would work.  It doesn’t work!!! My other Sonos products work fine. I’ve tried everything including wiring directly into router.  Geez sonos help. Oh your call wait time is 110 minutes really ?

I made it work by logging out of the app then back in again as suggested by a member of this forum.

Geez that worked!  Thanks

I’ve had same issue with my new Ray. Customer support is non-existent.