Question

Ability to change TV Playback to 'Full' in surround sound settings

  • 15 October 2019
  • 4 replies
  • 66 views

It would be a great addition to have a ‘TV Playback’ option in the surround sound settings, in the same way that there is a ‘Music Playback’ Option that can be switched from ‘Ambient’ to ‘Full’.

Often times for movies, it would better to have the surround sound speakers actually push through vocals/words and main audio sounds, rather then just background music or ambient noise. In the same way for music setup, sometimes its better to hear a full range of sound/audio.

Hopefully this makes sense, as the added ‘Music Playback’ option was a fantastic update!

 


4 replies

Userlevel 7
Badge +22

Hi Kruger

Your request would be a neat trick if it weren’t for buffering. Let me explain…

When music is played on Sonos speakers you are actually hearing a “buffered”output which allows Sonos speakers to play in unison regardless of their location in the room or your home. 

TV audio has to be direct in order to keep the spoken words in sync with the actors lips therefore any Sonos sound bar is wired directly to the TV to mimic the built-in speaker response. This is the same senario for any manufacturers soundbar. 

Although Sonos in general operates on the 2.4Ghz frequency the surronds and sub actually use the faster 5Ghz frequncy to keep the surround and LFE material insync with the action audio of the Beam, PlayBar, Playbase or Sonos Amp (with 3rd party speakers). 

Not buffering TV audio is why Sonos speakers that are grouped to a Beam, PlayBar, Playbase or Sonos Amp (with 3rd party speakers) expereince an approximate 70ms delay (across the 2.4Ghz frequency) which causes a “stadium” effect.

If you really need more voice audio you could possibly switch the output to stereo which would channel most of the vocal audio (except LFE if a sub is involved) to the Beam, PlayBar, Playbase or Sonos Amp (with 3rd party speakers). 

I hope this helps.  Cheers!

Hi AjTrek,

thank you for taking the time to provide that in-depth explanation

Do you know where I would change the output to stereo? is it in the Sonos app? I checked the TV settings but it only has PCM, Dolby Digital and Dolby Digital Plus.

It seems like a pretty complex issue, even increasing the ‘TV Level %’ in Sonos app to 15% causes some ‘stadium’ effect of audio at different scenes. The TV does have built in audio delay settings that could work together with Sonos if they were able to create a consistent buffer that could then be matched with the TV, so the audio could sync up with the video.

Then add it as a toggle setting for people who have TVs that can add the audio delay.

Really appreciate your help!

Userlevel 7
Badge +22

I was referring to the settings in your TV audio menu. PCM is the stereo equivalent over optical.

Got it thanks,

Yeah the audio quality is noticeably worse while using PCM, so ill stick with the dolby digital, thank you for the suggestion tho

Reply