Question

2019 LG OLED65E9AUA Magic Remote and Sonos Playbar

  • 25 December 2019
  • 9 replies
  • 498 views

Just got the Playbar and 2019 OLED65E9AUA TV and have tried setting up the magic remote so it can control the volume of the Sonos Playbar with no success. I initially used the Device Connector to go and set up the sound bar using Sonos and optical. It finished fine, but when trying to set up the control on the Sonos app, I keep getting stuck where it says to press + Volume.

I read up on issues with the magic remote and playbar and have tried: 1) changing the broadcast location to Mexico, Canada, Other (didn’t have a Germany option like I read in one post), 2) using Philips in the LG device connection menu… the Remote Type option didn’t come up, only a Power Button showed, and 3) disabling the Simlink option.

Outside of some magic elf dust, I don’t know what to do to make this work.

Thanks all in advance for your help.


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies

Badge

I have just bought an LG OLED55B9P LA and have the same problem in that the Playbase can not be controlled by the LG Smart Controller.

Check the TV firmware is up to date and then using the LG ‘device connector’ setup a universal remote for the port connecting the HT device (optical port). Choose the soundbar device option and you get to the manufacturers page, search for Sonos and select that in the results screen.

Finish setting up the universal remote and then goto the Sonos App ‘Settings/System’ goto the HT room settings and setup the remote. You will be promoted to president the volume up key on the LG magic remote to complete the setup.

Hope that helps to get your LG TV up and running with Sonos.👍

Thanks for the replies. @Ken_Griffiths. My TV firmware is up-to-date and did those steps at least 5 times with no luck. Any other suggestions?

Thanks for the replies. @Ken_Griffiths. My TV firmware is up-to-date and did those steps at least 5 times with no luck. Any other suggestions?

If using a connected cable TV box then program that remote instead. It’s strange though, as I have this working for the LG C9 TV and the Sonos Beam.

@Ken_Griffiths   Thanks again Ken. Would prefer to use the magic remote since it has a number of nice features. I called Sonos support and they told me to call LG. I called LG; they told me to call Sonos… 

Still not working and Sonos Customer Support keeps telling me to do the same thing… select Sonos in the Device Connector or Philips. Doesn’t work on this remote. :(

indigo1,

Thinking a little ‘outside the box’ ...

Maybe try this alternative possible solution instead, I’m assuming your Cable TV is connected over HDMI and supports HDMI-CEC control of the connected TV.

Get your cable TV IR remote and set it up, so that it is programmed to work with your LG TV volume controls. This is often done by entering a setup (pressing certain buttons on the remote) and entering a 4 digit code directly into the Cable TV remote.

You should then have two remotes that control the TV volume both the magic remote and the IR cable tv remote, albeit using HDMI CEC via the Cable TV box.

Then setup the Playbar using the cable TV remote (not the magic remote) and see if your magic remote will also now (hopefully) work with the TV provided you have setup the magic remote to act as a universal remote for your Cable TV box and IR remote for the soundbar, it may work, but this is just ‘a shot in the dark’.

I’m just not sure though if you may lose control of the TV volume when the cable box is put into standby mode of switched off, but it’s perhaps worth a try?

That’s the only other suggestion I can think of at this point in time. I’m just not sure if it will work however.

 

Indigo1,
I spoke to a friend of mine about your issue here and he suggested that you setup the Playbar again on the optical port using the Sonos TV manufacturer (in the soundbar section of the LG Device Connector) and make sure that you have sound on Live TV rather than the cable box TV.

In other words, make sure that the remote is able to raise, lower and mute the TV volume for the live TV, rather than the cable box. Best if cable box TV is just left in standby mode.

Then make sure the Sonos App is closed fully (slide off screen).

Turn off the TV (just place in standby mode) and then open the Sonos App and navigate to “Settings/System/Playbar Room” and now try again to setup the ‘TV Remote Control’ whilst the TV is powered off and use the ‘magic remote’ volume-up key when prompted and see if it works then, whilst the TV is in standby mode. 

So that’s maybe worth trying too.👍

-removed my proposed solution as the workaround did not last