Unable to turn on/off TV through voice command (chromecast)

Userlevel 1
  • Contributor I
  • 5 replies



I have a weird issue. For years I have been able to turn on/off my TV through voice command using google assistant on my Sonos One. Suddenly this has stopped working, and the google assistant in Sonos says “Sorry unknown error has occured on [name of my chromecast]” (this error might not be precise, I have translated it from my native language).


I am able to for example pause/unpause the chromecast using voice command.


If if say the exact same turn on/off command using the Assistant app on my phone the TV turns on/off.


I have tried unlinking/removing my assistant both in Google Home app, and in the Sonos. Linked it again, and went through the setup process, but the same error occurs. I have also tried renaming my Chromecast (found that advice in a similar thread), but same result.


Both my Sonos One and Chromecast has newest firmware.


If i go to https://myactivity.google.com/ and filter on assistant, I can see the command, and here it also says that unknown error has occured.


Anyone else experienced this problem, or have any advice on how to debug this?



36 replies

The Sonos actually says it has problems with TWO TVs. I assume one is the Chromecast Ultra, the other one I don’t know. There is a ghost Chromecast among the Google Assistant units, but not in Google Home. And again, the Google Assistant is not complaining on other devices than Sonos.

I have borrowed a Google TV and it’s exactly the same issue. Very frustrating!


Same issue. Hope this gets fixed as it is one of the most used command/feature in our household.


In general the assistant has become worse over time as well, but I guess that is somewhat Google's fault.


Sad that the product is now a lot worse than it was when I bought it. Doesn't make me motivated to buy more if this is what happens.




Userlevel 1

I have the same issue. I was able to ask Google Assistant on Sonos to turn off a Chromecast, which then in turn used CEC to turn off the TV. But, suddenly it stopped working.


Troubleshooting the issue led me to believe that it has something to do with the version of Google Assistant SDK that the Sonos system is using. If I ask the command “Hey Google, turn off <name of chromecast>” on a Google Nest Mini or the Google Assistant app on my iPhone, the command works. If I ask the same command to my Sonos One, I get an error message back in the line of “Sorry, something went wrong with <name of chromecast>” (this is probably not the exact message, since I’m translating it from Dutch). If I then go onto  https://myactivity.google.com/ to find more debug information (which can be found by clicking on “details” shown at the end of each command), I do see that

  1. Asking the command to a Google Nest, the source is “Google Home”
  2. Asking the command to the app on my iPhone, the source is “Google App”
  3. Asking the command to Sonos One, the source is “Google Assistant SDK” 

I also have an instance of Home Assistant running on my network. This piece of software can be configured to control Google Assistant as well, which also uses the Google Assistant SDK. If I execute my command via this route, the voice command is being executed without an issue. This means I can build a work-around, but it is not a perfect solution (have a look at Home Assistant and their Google Assistant SDK integration if you want more information: https://www.home-assistant.io/integrations/google_assistant_sdk/).


All the above led me to believe that the problem lies in the version of Google Assistant SDK that Sonos is using in their System. But, of course, this is only a hunch. Only Sonos knows.


I already contacted Sonos about this issue. The first support engineer did not believe me that this command worked in the past. The statement was made that “Sonos does not support this command”. And he stated that if it worked, it was by accident. Obviously, this is incorrect, because Sonos does not control the feature set of Google Assistant (since they are using Google Assistant SDK). Also, the response is clearly an error message, not a message stating that the command is not supported. When Google Assistant does not support a given command, it will tell you explicitly, not via an error message. He then just put a bunch of statements to get rid of me.


After I was very negative in a survey by Sonos, they reached out to me again to solve this issue. This next support engineer I had on the phone was a lot better and more knowledgable. She told me that Sonos is aware of the issue, and that Sonos is looking into a solution for this problem. She was not allowed to disclose any information about this issue until (or even if) it gets resolved. Fingers crossed!

Userlevel 1

Thanks for your very detailed answer HansDP :)

Let’s keep our fingers crossed, it is a function we used all the time at our place.

Try removing Google voice assistant from your Sonos app--then use your phone or other smart speaker. This magically fixed my tv on/off via Sonos Arc function. I don't get to use my Arc microphone anymore for GA, but it wasn't as good at interpreting commands as y phone and Google smart speakers anyway.

Bump - same issue ☹️


Until now I hadn't added a voice assistant to Sonos. I added Google Assistant yesterday so I could remove a nearby Google Nest, and my most-used feature - turning the TV on or off - stopped working. It's so strange! Other than that the Google integration seems to be great. This is frustrating and disappointing! Hope it does get fixed although the age of this conversation suggests not... 🫤 I don't want to go back to using the Nest as it often can't hear over the beautiful sound of the Sonos 😅

Userlevel 1

@Sonos - I’m checking in again after half a year. Any update? Any solution in the making?


it is clearly an issue that bugs quite some people. I do know that Sonos and Google are not best friends right now, due to the lawsuit and what not. Obviously, that will not speed up any solution for this. I think we all just expect a solution within a reasonable amount of time. 

This feature worked before and other integrations support the on/off command for a Chromecast (even the free and open source Home Assistant does support it).


Hope to get an update or a statement soon!




This has been annoying me for months. It used to work, and then it stopped working. 
Finally i found a workaround that works for me. 

When i link sonos in google home app, i now get the option to add the «sonos tv control».

I place this in the same room as my tv (which is connected to the sonos beam). I name this controller «TV». I can now say «ok google, turn off TV» and the TV turns off. 

This has worked for me too! So happy ☺️😁😃

I have received a complete set of Sonos Arc + Sub + 2x Era. I have set it up last week and turning on the TV was absolutely fine.


After some connection problems i have setup Google Assistant from scratch and now have the exact same problem.

Turn on TV command where from Google Home or Google Assistant app but not from Sonos App.

Any ideas? The work around above results in the same issue.