Sonos TV Control in Google Home app not responding


Hi there,

I have a Sonos Arc connected to my TV using the hdmi cable into the ARC port.

I added Google Assistant during the setup process and in the Google Home app, I see "Sonos TV Control" correctly located on my living room, but when I say "Hey Google, turn on the TV" I get a response from the TV too confirm it will turn it on but it never does.

When I open the "Sonos TV Control" device in the Home app, it shows as "not responding". I have deleted and reinstalled a few times but it's still not consistently responding.

Can you help?

 

 

 

 

 

 

 


17 replies

Userlevel 5
Badge +14

Hi @bambo_k.

Thank you for reaching out to Sonos Community.

Since the Google Assistance is not responding properly in some of your commands, I suggest contacting Google Support this might be related to a software issue with Google.

Some of the community members might provide their own opinion about this.

 

If you need help with any other information, please be sure to let us know.

Userlevel 7
Badge +17

What TV are we talking about? This feature works well on my Samsung QE65Q90 - it’s a feature Samsung does not offer themselves.

Badge

Hello Guys,

 

I had my old Samsung Ks8000 tv and now changed to a 2020 Samsung TU8005, before with my BEAM, the google and Alexa were both working to Turn ON and OFF the TV.

 

Now with the new TV, I can turn ON 👍🏼 But I can’t turn OFF 👎🏼
 

Any suggestion?

Hi there both

My TV is a Samsung 65HU9000

I don’t think it’s a Google Assistant issue as far as I can tell.

The funny thing is, I have to turn it on manually using the remote (since voice commands don’t work to turn it on) but turning it off with my voice works - so I don’t get it

 

Any other advice?

And thank you for your help, of course!!!

Userlevel 7
Badge +17


This is what my Google Home app says about my living room. “Huiskamer” is my Beam (plus two Ones and a Sub), I’ve added the Samsung TV via the SmartThings app, but that doesn’t turn the TV on as Samsung does not allow this. I’ve added Sonos TV Control to this room, so when I say “Hey, Google, turn on Sonos TV”, the Beam turns on the TV. What is your set up?

Have pasted my setup below. My Samsung TV doesn’t appear (maybe it’s too old). But the Sonos Arc is plugged into the ARC HDMI port so it should be able to switch on the TV. When my Chromecast was plugged into the ARC HDMI port, it would turn on the TV as soon as I hit “Cast” but now the Arc is plugged into the ARC HDMI port, the TV doesn’t switch on automatically when I cast

 

Userlevel 7
Badge +17

And when you ask Sonos TV Control to turn on the TV?

It replies “Got it, turning on Sonos TV” but then the TV doesn’t turn on

Userlevel 7
Badge +17

Then, if you've not already done that, I'd take a look at the Anynet (HDMI-CEC) settings. If GA says it's telling Sonos to turn on the TV via HDMI (although this is also not a 100% success on my Samsung) Sonos and GA do not seem to be the problem. 

Ok, will do and let you know. Thank you!!

I have the same problem, but with a vizio tv.

I'm still having the same issues after many months :(

I have personally found that giving the Sonos TV Control a ‘nickname’ of ‘TV’ worked for me - "Hey Google, turn ON (or OFF) the TV” both seem to work okay, but I also had to switch on HDMI-CEC on my TV .. I understand the HDMI-CEC standard has different names depending on TV manufacturer… here are some of them:

  • Samsung - Anynet+
  • Sony - BRAVIA Link or BRAVIA Sync
  • LG - SimpLink
  • Sharp - Aquos Link
  • Vizio- CEC
  • Hitachi - HDMI-CEC
  • AOC - E-link
  • Pioneer - Kuro Link
  • Toshiba - Regza Link or CE-Link
  • Onkyo - RIHD (Remote Interactive over HDMI)
  • Panasonic - VIERA Link or HDAVI Control or EZ-Sync
  • Philips - EasyLink
  • Mitsubishi - NetCommand for HDMI
  • Runco International - RuncoLink
  • Insignia - InLink
  • JVC - CEC
  • Magnavox - Fun-Link
  • Sylvania - Fun-Link
  • Sansui - EasyConnect
Badge

I have exactly the same problem as bambo_k. Turning on  the tv doesn't work. Google assistant answers, but nothing happens. Turning off the TV is no problem. "Sonos TV control is not responding". 

Initially, everything worked fine, but this was only temporarily.

Any suggestions ? I will try to reinstall everything next weekend.

 

 

Userlevel 5
Badge +11

Hi @JSo, and welcome to the Sonos Community!

I’d recommend starting by rebooting your Router, Sonos Home-Theatre device, and TV, and seeing if this resolves the issue.

If not, Ken has posted a list of common names for CEC based on the TV manufacturer directly above your post, mind finding the relevant setting in your TV, and then disabling and re-enabling the CEC function?

Let us know if this helps at all :)

Badge

Hi @JSo, and welcome to the Sonos Community!

I’d recommend starting by rebooting your Router, Sonos Home-Theatre device, and TV, and seeing if this resolves the issue.

If not, Ken has posted a list of common names for CEC based on the TV manufacturer directly above your post, mind finding the relevant setting in your TV, and then disabling and re-enabling the CEC function?

Let us know if this helps at all :)

Many thanks @Xander P. I've rebooted the Sonos Beam. Now, my tv is responding correctly. However, the Google Home app is still showing "Sonos TV control is not responding". Disabling and re-enabling the CEC function did not help. I will try rebooting my router.

Reply