Sonos Roam not connecting to Google Assistant

  • 30 December 2023
  • 3 replies

My new Sonos Roam won't connect to Google Assistant. I tried using the Sonos Voice Control instead but that is not compatible with either Spotify nor BBC Sounds and is therefore pointless. I have looked at every single existing support thread on this Community Forum and followed the advice of them all, and nothing works. 

I have only one Google account, and my Roam and phone are both connected to the same WiFi network. I have no other voice control currently installed on the Roam. I have tried unlinking my Sonos account on Google Assistant/Home, I've tried restarting all devices and the router, and deleting and reinstalling apps. Nothing works. 

I select to add Google Assistant voice control on the app, and select my Roam as the device (I own no other 'smart' speakers etc), and click to add Google Assistant again, and then I just get the error message below every time saying "There was a problem adding Google Assistant". I got try again and nothing happens. 

I've submitted diagnostics twice. No response first time, second time my code is: 394168385.

Please help!



Best answer by Ken_Griffiths 30 December 2023, 01:26

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

I would perhaps next try a different mobile controller device - it might be something running on the mobile that’s causing the issue, or a permission. I’ve just tried this on my iPhone and the Google Assistant has installed fine on the Sonos Roam here, so it’s possibly something local.

(Screenshots attached from my Google VA test here a few moments ago on Roam called MotorRoam)

Note that unless you call in, submitting a diagnostic does nothing. You must contact them in order for them to go into the database and look at it. See the Diagnostics - How do they work? thread.

I have exactly the same problem. Brand new Sonos roam. Done everything the same as you have. I just keep hitting a brick wall with "There was a problem adding Google Assistant" I have just spent 3 hours on this. Sent diagnostics to customer  service but they just said all looks ok and suggested a reinstall etc. My phone is a Motorola G62. Did you get a solution @jonnypcasey?