Answered

Sonos one gen 2 - cannot connect Google Assistant

  • 12 February 2024
  • 4 replies
  • 212 views

I just bought Sonos One and trying setup google assistant on my android phone using S2 update
I did following steps:

  1. Start connecting to google assistant
  2. when google device wizard appears (sometimes it dont) it redirect me to sonos site which promts me information about how can i open settings
  3. when I am pressing continue, I am seeing message that my speaker was not registered in my sonos account 
  4. When i am checking my web account page, it clearly shows me date when my device has been registered. I cannot register it manually again. I am stuck at this step

I am hoping to find help here,  i checked other similar topics they seems like had different issues 

icon

Best answer by Ken_Griffiths 13 February 2024, 02:41

View original

4 replies

It maybe best to reproduce the issue and grab a screenshot of the error message about the Sonos One not being registered in your Sonos account, then immediately submit a Sonos system diagnostic report from within the Sonos App, note it’s reference and then contact/chat with Sonos Support Staff via this LINK and see what the Staff can perhaps suggest to resolve the matter.

The issue eventually resolves itself: during next day I be able to finally setup GVA on device

I have a Sonos Beam and tried everything to make it work with Google Assistant.

The one thinig that did work was to unplug router for 30 seconds, unplug Beam, turn off smart phone.  Turn on router and wait for it to reboot, turn on smart phone, plug in Beam.  When I went back into Sonos App to add Google Assistant, IT WORKED!!

 

Unplugging the router seemed to be the key!

That seems a lot like a duplicate IP address issue, so rebooting the router f the Sonos is off/powered down would indeed be a huge help.

Reply