Sonos Move and Google Assistant

  • 25 November 2020
  • 4 replies
  • 105 views

Some more background I am using youtube premium account and I use the same account on a harmon cardon citation device with google assistant and my personal phone. Youtube premium support up to 10 devices and so I configured google assistant on the sonos move. 

 

harmon cardon citation device is about 20 feet away from the sonos move and separated by 10 walls. The point being there is no interference.

 

I ask the same questions to google on sonos move and it doesn't know the answers! however the harmon cardon citation device can *google* and get me the answers! 

 

Even small things like “play instrumental jazz music” does not work on sonos move. The error I get back from sonos is “Sorry I can’t find what you asked for” 

 

“Play soft rock music on youtube music” the response I get back from sonos is “Sorry I can’t find what you asked for” 

 

All of this does work on the harmon kardon citation devices!! This is ming boggling to me I verified my youtube account credentials on the app, ensured google assistant is connected, ensured that devices are 20 feet apart, and still the sonos music does not seem to support google assistant!! this is horrible...

 

Is there someone who can help out?? 


4 replies

Userlevel 5
Badge +16

Hi @kanzi.

Thanks for reaching out and welcome to the community!

I appreciate your detailed post outlining the issue as well as the step(s) that you did, let me help and try to figure this out.

  • To ensure that Google Assitant heard the command clearly, you can check in the Google Assistant app to see what your Google Assistant heard: myactivity.google.com
  • Please ensure that you're specifying the room name when initiating playback. For example, if your player is named Office, you will say "Ok Google, play The Beatles in the Office."
  • Try to remove and re-add your Google Assistant from Sonos.
  • You may check this article that contains additional guidelines and troubleshooting steps to follow.

 

If the above advice was followed and the issue persists, please submit a diagnostic report, and reply with the confirmation number, I'd start by reviewing your system and see if there’s anything causing this issue.

 

Let us know how it goes and if you have any questions feel free to reach out, we’re always here to help.

So I made sure that all the activity is logged and is perfectly accurate in myactivity.google.com

 

I also started specifying which room to the sonos move.

 

I did remove and re-add the google assistant and it works only the 1st time. So it plays the music etc. all only the 1st time once you re-add the google assistant and then somehow it loses the connection/sync to google assistant!!! This to me seems like a critical bug in the implementation. 

 

I have reproduced the issue multiple times and here are all the ticket numbers for the logs submitted by me: 10006220, 755388381, 877348121,1166626687, and1941226035. 

 

Please let me know if you need more details? FYI this piece was purchased from amazon.

 

Hopefully, someone can help me out! I genuinely like the product and don’t want to return it :-( 

 

 

@Annazel S FYI

Userlevel 5
Badge +16

Hi @kanzi.

Thanks for your response and effort in submitting the diagnostic.

Upon checking the diagnostic reports, there’s no issue found on the system but it’s odd that I see no cloud connection on the Sonos Move.

I suggest that it might be best to reach out to Sonos Support so we can take a closer look at this and continue working with you in real-time to expedite the process. I recommend our phone team for they have more resources available on their system for advanced troubleshooting, and the tools our agents can use would be very useful in this case, there can be an advantage if they need to remote into the controller to see what's going on.

 

If you have any questions, please feel free to let us know.

Reply