Answered

Roam wont connect to google assistant

  • 24 April 2022
  • 4 replies
  • 186 views

Hi, was hoping someone could help me out. 
I’ve just purchased a Sonos Roam and have a few issues. My existing setup is only very basic with a google home and several google tv devices, all running on the same network. The Sonos Roam is my first Sonos purchase. 

Firstly I can’t install google voice control on the Roam. I follow the steps on the Sonos app to add a voice assistant, and when it opens the google assistant app to look for devices, it can’t see the Roam. After looking for devices it fails and says to ensure WiFi is on and that your iPhone and assistant devices are on the same network. WiFi is definitely on and everything is on the same network. 
Also, I can’t get the Google home to see the Roam and stream to it. When I open the Google home app the Roam is listed under devices along with my other google products, and says it is linked, but when I select media on the app the Roam isn’t listed. 
Any help would be much appreciated. 

icon

Best answer by Ken_Griffiths 24 April 2022, 11:22

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

First try removing the Sonos Skill in the ‘Works with Google’ area of the Home App and give it a minute or two. Then reboot your local router & Roam and when everything has reconnected and settled then goto the Sonos App "Settings/Services & Voice” and try adding the assistant to the speaker again.

Note: you may need to check/ensure the Google ‘Assistant’ App is signed into the same Google Account as the Google Home App and double-check your mobile has re-connected to the same wireless network access point as your speaker. Hope that works for you.

Hi Ken

Thanks for taking the time to help, it’s much appreciated. 
Unfortunately I have had no luck. 
I have removed the Sonos Roam, rebooted everything but get the same result (multiple times)
I only have one Google account and one wireless network to connect everything to, so there should be no mix up there. I might have to contact Sonos to resolve the issue. 
thanks again 

Is there perhaps any security software running on your mobile, like Antivirus/Firewall or VPN, if so then switch that off. Also perhaps try a different DNS on your router, try using the Google public DNS servers 8.8.8.8 or 8.8.4.4 - also ensure your ‘Language’ settings in your Google account are set to ‘Australia’ and that your online Sonos profile has that set as the same Country aswell.

https://www.sonos.com/myaccount/user/profile/

There is no security software on the mobile. I’ll try a different DNS, but it’s a bit beyond my skill set. The languages all appear to be set correctly. 
I hope I can get it all up and running, the roam was to be the first of many Sonos products, but it’s really starting to test my patience 😕
Thanks again for your help