Problems with Google Assistant on Sonos One


I've owned a pair of Sonos One for about 2-3 months now and they are amazing. Especially since Google Assistant launched for Sonos speaker in the Netherlands last month. The first few weeks were very good and I had little complaints. But since 1-2 weeks Google Assistant stop responding to even the most basic questions. Only when I stand next to the speaker that has the voice enabled and I talk really slow she sometimes understands what I mean.

We have our Google Assistant in English, since my girlfriend is Swedish. Even tho there is bilingual support in Google Assistant there is no way to name rooms/devices in Dutch and Swedish. So we choose the middle ground and set everything in our house in English.

I've already tried the following:

  • Setting it too Dutch. It's now in dutch and it's far from perfect. But she does seem to respond a bit better now. But this is not a solution.
  • Rebuild my entire home in the Google Home App
  • Factory Reset both my Sonos One Speakers

I'm getting a bit desperate in finding a solution, since we spend the money on these speakers to use it with voice function and control of our house.

Does anyone have a solution for this? Or even the same experience that there was a sudden change in functionality of the Google Assistant on Sonos One or other products? Especially if there are any Dutch people experiencing the same problem.

Thanks in Advance,


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

25 replies

Hi Kevin, I'm experiencing exactly the same. Since a few weeks the assistant is completely unreliable. Before the launch in the Netherlands I used a US address in my Sonos and it worked like a charm. It was above expectations to be honest. Since a few weeks and a million attempts to fixing it it's working maybe 1 in 10 commands. It's driving me totally crazy because it was so nice to have the working situation. I saw another thread with the same issue. Also a Dutch user. I factory rebooted everything. Including the Google assistant on my phone. Nothing helps. I hope Sonos can clear things up because I'm out of ideas
Exactly the same, also dutch and in english and dutch the speaker. Half of the time the speaker doesn't respond to my commands, and when I ask to turn on a scene, which it can, it says: that hasn't been setup yet..
Worked good for a while but now only frustration. And the thing is, my google home mini DOES return the commands correctly that I say, so it's sonos..
Hi Kevin, I have exactly the same problem - is there any solution? I know it is Sonos problem it assist works fine on my phone. Willem

See my reply to your post here... just wondering what the feedback was from Sonos and if you’ve perhaps explored some of the things mentioned?
I have the same problem. But i bought the Sonos One just today, so i thought i was bevause of my own faults during the installation. Very strange: the first 10 mimutes no issues with the assistent but now it doesnt answer anymore.
And it's a sonos problem cause google home mini responds perfectly
Hi the same here. I also bought the One recently and are a fan of both Sonos (for years) and Google Assistant (for one year). I also have an LG and Sonos Home mini and both are performing better as the ONE. It is slow, recognise my voice not all the time. Also functionality is not the same as LG: for example the translation mode.

Try in Dutch "Google help me om Engels te spreken". You can then use the Mini of LG as translator from Dutch to English and English to Dutch at the samen session. This does not work on the ONE. Why??

Also if you look at the Voice Match settings, only my LG and Home mini are listed, no ONE. Although I tried reinstalling, train again the Match option etc.

I'm disappointed to be honest and would expect a better product from Sonos, hope they correct soon.
Same problem with my Sonos One's.

It feels like the Google Assistant software on Sonos is many versions behind the one available on Google devices.

You would think that with the massive delay on getting Google Assistant available on Sonos that it would be a perfect integration by now... reality is far from that.
The Google assistant lives in the cloud, not on the individual devices. The devices just provide a method by which you voice gets transmitted to the cloud processes.
The Google assistant lives in the cloud, not on the individual devices. The devices just provide a method by which you voice gets transmitted to the cloud processes.

Thanks! You're right indeed. :)

Regardless, I am turning off the mic on my One's and putting back my Google Home Mini.

Hopefully, Sonos will do better in the (near) future.
The Google assistant lives in the cloud, not on the individual devices. The devices just provide a method by which you voice gets transmitted to the cloud processes.
Hi Airgetlam,

You're completely right with that, but still the support in the different devices is different. The Sonos One reacts as it a Google Assistant service from a smartphone but not as a Smartspeaker. That's why this is so strange. Why is there a difference? What is causing this? I also have a LG Smartspeaker which is reacting exactly the same as the Google Home mini.

Another example. Ask Google on the Sonos One 'what is the latest news'. Have of the times It does not answer and also in the activities there is no logging. There is no other smartspeaker on the same floor even. And the second is that you can't stop the broadcast by saying 'Hey Google, stop', it just stops for a moment and then resumes.
On the LG and Google Home mini this works everytime.😥

I had a similar issue. Since a week, Sonos stopped understanding basic commands like Play Joe Fm on Tune-In or Volume Up or Down. It did react on the Hey Google wake up but didn’t understand a thing after that.

Here is how I fixed it:

I browsed to:

Make sure you are logged in with the correct google account.

On that page you see a list of all the commands you ever gave to your google assistant and browsing history.  To make it easier and only see assistant commands, you can press the Filter button and select Assistant.  It will only show commands.

The long history list seems to confuse Sonos.  So press the “thrash can” button next to the Today and all the other dates.  I had to press many times because it keeps the history day by day and there is no delete all history button.

After that, select the main “My Activity” menu on that page and select “Activity Controls”

Uncheck the two boxes in Web & App Activity.  It pauses google recording all your activity.

This fixed the problems and I could again have a meaningful conversation with my Sonos One.

For example a command like Volume 1 or Volume 2 did not work anymore at all.  Since I went through the above steps, these work again.

Despite the fact that I disabled “Include voice and audio recordings” in the “My Activity” section, it still seems to register all commands in the history.  So I may need to clear this in a month from now again.

It would be great if the Sonos team checks why this activity history is such a problem with the Sonos One. Because it isn’t with other devices like Google’s own Home devices.

Have there been ANY responses from Sonos about this ?? 

Its very frustrating. I have a google home mini, but bought two Sonos Ones to replace this. It looks as though I’m going to have to place the google mini in the room with them. What a waste of money! 


Sonos.. Could you please respond to this? 

It has again been unresponsive to volume commands for the last week. You can ask the Sonos, questions, like “Who is Donald Trump” and it never misses.  But a simple Volume Up or Down command is a hit and miss experience.

Strange: since this morning it understands volume commands again. Very frustrating. 

I’m having the same issues in Germany, but only with my One Gen 2. Up until recently it worked. The Beam works perfectly. The comments also don’t directly appear in the My Activity log, while the one from the Beam are directly there. They show up later as Unknown voice command.

Thanks very much JD Moons. Your fix solved my problem. I cleared the historical commands into my activity and now the device works properly.

I suspect this happens when you set up multiple languages.

I bought the Sonos One only a few weeks ago. Initially I set it up in English and it worked fine. Then I added a second language in the google assistant app (french) and it seemed to work only well in French and not so well anymore in english. I removed the french language and it was not working very well anymore since then. I have reset the sonos and the google asssitant app but nothing was working. Now I have cleared the acitvity and works again like a charm! Let’s see in a few days how it is going to evolve! So far i haven’t unchecked the history recording of the commands.

Exact same experience as OP. Clearing the activity history hasn’t solved it for me unfortunately. So frustrating 

Exact same experience as OP. Clearing the activity history hasn’t solved it for me unfortunately. So frustrating 

It’s working okay here for me in the U.K. Perhaps try clearing the Sonos Skill in the GH/GA App and when the speaker rooms are cleared from your Google Home, add the GA to your Sonos speaker(s) again via the Sonos App “Settings/Services/Voice” menu option.

Three things to also double-check are that you have the following…

  • Just one language installed in the GA location settings.
  • That you have just one Google Home on the Account 
  • That the chosen ‘paid subscription’ only Music Service, set as your default service in the GA/GH App is also installed as a service within the Sonos App using the same login credentials. 

Hope that helps to get you up and running with GA on Sonos.👍

Same issue here on a new Sonos Move (diagnosis ID: 1477074619)

Google Assistant responds to a handful of basic commands (what time is it, what’s the weather) but never responds for anything more complicated (skip this song, what’s this week’s forecast, what’s my first meeting). 90% of the time, these queries have no response at all or I get “Sorry, something went wrong”.

My Google Home Mini with the same account on the same WiFi has none of these issues.


Here’s what I’ve tried (none of which have worked)

  • Factory reset of Move
  • Unlink then relink Assistant in iOS Sonos, Home and Assistant apps
  • Delete and re-install Assistant and Sonos apps
  • Connecting to a different Google account
  • Changing language from UK English to US English

This issue has been happening for months. I bought the Move specifically for its Assistant integration so this is extremely disappointing and Ive wasted hours trying to resolve the issue.

Hi @csmith. Thanks for posting.

I have taken a look at your diagnostic and I would like to know a little more about the network you are running. 

What is the make/model of your router? Additionally, please ensure the router meets our network requirements.

Regarding the commands on the Google Assistant service, would you be able to quote actually how you are asking to perform the advanced commands? 

I would recommend this be done with no other Google Assistant devices in the area. If possible, I would even recommend temporarily unplugging those units.

I am having similar issues with my Sonos 1’s.  I’ve connected them all into Google Home and have enable Google Assistant.  Some of them work just fine, whereas others don’t seem to work well at all.  For example, I can say to my Sonos 1 in my den: “Hey Google, play Sublime in the master bedroom,” and music will play in the Master Bedroom.  However, if I go into the master bedroom and say exactly the same thing to the Sonos 1 in there, it will tell me “I can’t do that here, but you can ask me to play it on one of your other devices.”

Weirdness. I’ve tried removing and re-enabling the Assistant from all of the devices. Still inconsistent behavior. Can I get some help?  I’m about to disable the Assistant on all of my Sonos’es and buy a few Google minis for throughout the house.

Userlevel 1

Sonos One is completely useless for Google Assistant.

I have devices for Google Assistant from Google, Lenovo and JBL,  They all work well, and respond to the same commands in the same way.

The Sonos One is hopeless - completely and utterly useless.  You have to yell at it, but the worst is that it responds in a completely different way to the other devices, and does random things unrelated to commands that are completely reliable on my other devices.

I have also used Alexa on the Sonos One - no such issues when compared to ‘real’ Alexa devices.

Sonos, are you going to do something about what is clearly a critical failure of your device, or going to resort to form and treat your customers like you did with the ‘trade up’ program, or the S1 to S2 ‘screw our historical customer base’ efforts?




Userlevel 6
Badge +15

Hi everyone, thanks for reaching out to the Sonos Community.

For those of you having trouble with Google Assistant, here are some recommendations;

It’s always a good idea to start with a network refresh, which you can perform by rebooting your router (turning it off for about 15 seconds before turning back on), followed by each Sonos device when the network is back online.

If using a mesh system in conjunction with an ISP provided router, it’s generally best to either have the mesh set to “Bridge/AP mode" or have the ISP provided router set to Modem mode, this will prevent Double NAT which can affect Voice Services - if you’re unsure about this, I’d recommend reaching out either to the mesh manufacturer or your ISP to assist in making these changes.

If there’s a general pattern you’ve noticed, for example that you need to ask the same question 3 times consistently, then there may be “ghost devices" registered in your Google Home app. If you open the Google Home app, and tap the Profile icon in the top right, then go to Assistant Settings > Devices, do you see any of your speakers listed multiple times? If so, I’d recommend removing any instances of that speaker, and then re-adding Google Assistant via the Sonos app > Settings > Services & Voice > Voice > Google Assistant > Add to Sonos.

If you’d like some assistance with any of this, then feel free to reach out to our Support Team via live chat or phonecall, and they will be able to perform some more in-depth troubleshooting with you.

Userlevel 4
Badge +6

Having the same problems here. This nonsense has been going on for more than a year now, so many things don’t work, and Sonos won’t fix it.

This doesn’t have anything to do with duplicate devices in the Google Home app, or WiFi problems. All Google Home/Nest speakers work, but Sonos speakers won’t, no matter what you do, even if you wire them up to your router.

I’m really tired of this. So many things don’t work, so many features are missing, and all we get are these generic responses faulting WiFi or saying it’s just some other user error, even though the problem here is the Google Assistant integration on Sonos devices, which sucks big time.

We keep getting told that our feedback will be passed on to Sonos’ technical engineers, or we’re being told to contact customer support, and nothing ever gets resolved.