Answered

Ongoing Issue with Multiple Play Requests Needed

  • 12 November 2021
  • 1 reply
  • 16 views

When I initially set up my Sonos ONE Gen 2 speaker it worked absolutely fine. I then got a separate Sonos ONE but without the mic function in order to set up stereo sound.

I'm not sure if it was since then or after but whenever I ask Google to play music from Spotify on my Sonos I have to initially ask it twice - Google will respond saying "ok, playing .... On Spotify" but then this is followed by silence until o repeat the command.

Similarly, when I try to cast from Spotify, I will often choose a song which will start playing, then cast it to my speaker but then have to pause and play the song again before it starts playing.

I don't know where the problem is, but I have noticed others have mentioned similar issues on these forums a year ago. I was hoping it would be a temporary bug but it has now been like this for almost a year.

Any ideas? My Google mini works flawlessly (and has full Google assistant functionality) but I do think the Sonos speakers are better quality so would like to get them to work before binning them off.

icon

Best answer by Ken_Griffiths 13 November 2021, 01:44

View original

1 reply

My suggestion is to go into the Google Home App and remove the Sonos ‘Action’. After a few moments the Sonos devices will be removed from the Home. Then reinstall the Sonos ‘Action’ and if necessary move the two Sonos speakers to the room(s) you want them in. Check the Google App to ensure that there is just the one Home only in the App and ensure that no other devices have the same name as your Sonos products. If necessary rename any similarly named device(s) in their own native App so that each item in the Google Home has a unique name. See if doing those few things then resolve your issue.

Reply