Answered

No Option for voice control

  • 6 January 2020
  • 5 replies
  • 1166 views

I’m trying to set up voice control through google assistant on my new Play one. However, in the app when I select services the only options are “music and content.” There is no “voice” options available. I’ve tried re-downloading the app and double checking that It’s updated. I live in the US so it is definitely available here. Any help would be appreciated.

icon

Best answer by Ken_Griffiths 6 January 2020, 20:43

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Which app are you referring to?  Google’s or Sonos? 

 

https://support.sonos.com/s/article/3486?language=en_US

The sonos app

Any chance your account is registered with an out of country address?  Are you using a VPN that’s giving you an IP address from a different country?

 

Actually, you already have your Sonos system connected to Google correct?  I haven’t looked at this in a while, but I believe you need to use the Google home app to search and add devices.  that will allow you to control the new speaker with GA.  If you actually have a Sonos One (not a play:1) and want to use the mic on the speaker, then you need use the Sonos app, go to the configuration for the specific room, and then add the Google voice service.

 

https://support.sonos.com/s/article/3467?language=en_US

No I don’t think so. I just have a standard router. I haven’t changed anything in it.

Lewis09,

Ensure your Google Assistant App has a single default location setting for the “Home” you have setup (eg. English (United States)). Check that is also your “country” setting in your online Sonos Profile home address here....https://www.sonos.com/myaccount/user/profile/

Fully close and re-open the App or even reset the Sonos App and connect to ‘Existing’ Sonos System (Do not create a new one).

Then see if the voice assistant option appears at the top the Sonos App “Settings/Services” if not then you may have an issue with mDNS multicast broadcasts not being allowed across your LAN by the router, so then try rebooting the router to see if that fixes the issue.

Hope that gets you up and running with GA on Sonos.👍