Question

Need help adding Google Assistant to Sonos One / Move - error 30

  • 30 December 2020
  • 1 reply
  • 54 views

I recently changed routers which required me to re-set up the Sonos speakers with Google Assistant. 

When I go to the Sonos app and select Add a Voice Assistant, the first thing it does it force me to do a system update.  It finds an update and requires me to update.  I keep getting an update problem - error 30.  This is related to an unsported speaker on the system that we are still controlling with the one Sonos S1 app.

 

How do I get sonos to ignore this speaker as part of the update so that I can add Google Assistant? 

Thanks!


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 5
Badge +14

Hi @hahspike.

Welcome, thank you for reaching out to Sonos Community, We appreciate your time and effort in posting your concern here in our community.

Error 30 occurs when one of your Sonos products tries to download the update file but is unsuccessful. If you see Error 30, the Sonos app will also show you the name of the Sonos product that is having trouble downloading the update.

  • Retry the update at least one more time.
  • Find the Sonos product that was named in the error message and move it closer to your router, then try the update again.
  • If the update still doesn't work, connect the Sonos products to your router using an Ethernet cable and retry the update in the Sonos app. If the update is successful, unplug the product from your router and return it to its original location.

Error 30 can also appear if you use the Sonos S1 app to try and update a Sonos system with products running both S1 and S2 software. The S2 products will show as “Incompatible” in the Rooms tab of the Sonos app. In this case, the products running the S1 software need to be reset to their factory settings and set up as a separate S1 Sonos system.

 

Also since you have a new router here are router settings that need to be verified. You can contact your ISP or the manufacturer of the router for assistance.

a. Auto channel must be set to Off

b. Choose best non-overlapping channel (1,6,11)

c. Set channel bandwidth to 20MHz

d. Both 2.4GHz and 5GHz should be enabled

e. 802.11 band should be set to b/g/n

f. Airtime Fairness should be disabled

Let us know if it works. If you need help with any other information, please be sure to let us know.