Answered

I can’t reach the internet right now check your modem or router connection and try again


The Beam google assistant worked fine for a year, but coincidentally around the time I’ve updated the iOS sonos app to v2 I couldn’t use the assistant anymore (I say hey google and get the response in the title of this post). I’ve managed to fix it twice by going through the google assistant and sonos app and reconnecting everything, but next day it comes back to this. Tried to uninstall the sonos app v2 and use the v1 again, but it can’t connect to it, probably because sonos v2 had installed a new firmware to the beam when I first installed it. 
 

is there a permanent fix to this?

icon

Best answer by Ken_Griffiths 9 January 2021, 17:33

Frustratedguy,


Just to add that when a sonos device is wired direct to a router, then all Sonos devices should switchover to their own internal SonosNet wireless signal/connection and removing the local WiFi credentials in the Sonos App is a good idea in that type of setup, as it stops the devices hopping between SonosNet and the routers WiFi signal.
 

It’s also best in that ‘wired’ situation to set the routers 2.4ghz WiFi channel and the SonosNet channel so they are at least 5 channels apart to prevent interference between the two signals. 
 

When none of the sonos devices are wired, the SonosNet channel selector should disable, as its irrelevant as all products then connect directly back to the router using the routers 2.4ghz WiFi signal instead.
 

In this situation, I suggest setting the routers 2.4ghz band to use a channel width of 20MHz as that reduces interference aswell.


Many routers appear to like channel 6 by default, so I tend to opt for channels 1 or 11, but it’s really a case of what works best for the local environment. I find that ‘fixing’ a routers channels seems to work best with Sonos and reserving (fixing) each of the Sonos products IP address in the routers DHCP servers reservation table is a very good idea too.

 

This Sonos video about wireless interference is also quite a useful watch:
Wireless Interference and Sonos
 

If your Beam keeps dropping when on WiFi, despite perhaps trying the suggestions above, then when you have it wired back to your router and it reappears in the App I suggest you submit a Sonos system diagnostic report and contact/chat with the Sonos Support Staff via this LINK to see if there are any issues with the Beams WiFi network adapter.

View original

11 replies

This sounds obvious but did try simply powering the Beam off and on again? 

If the internet connection is dropping as the title of your thread infers, then perhaps ‘kindly’ describe your network setup, so that some suggestions can be put forward for you to perhaps consider and try.

To maybe save time, it would be really helpful to know some, or all, of these few things mentioned below and what you may have already tried yourself to fix the issue:

  • If you are using a centrally based WiFi Router, or a Wifi mesh system?
  • Any other Wifi Access points/Repeaters/Power-line Adapters?
  • Any switches - managed or unmanaged?
  • If you are running your devices on SonosNet, or WiFi?
  • Which SonosNet/WiFi channels & channel-widths are currently in use?
  • How many Sonos products altogether and whether they’re using S1/S2 households?
  • If you have already chosen to fix/reserve the Sonos product IP addresses in the routers DHCP reservation table?
  • The type of Sonos controllers in use? - (Android/iOS/Desktop)

Well, I guess the info is perhaps only needed if @ratty’s suggestion doesn’t quickly solve the issue.

Tried unplugging the power, no juice. 
 

The beam is connected to a home regular simple wifi modem, nothing fancy at all. As I mentioned, it worked flawlessly for a full year. Nothing has changed in the setup other than installing the new sonos 2 app on my iphone. 

Can you perhaps give more detail, as mentioned in my earlier post.

Just as one very simple explanation... if the Beam is unwired, it is worth perhaps changing the routers WiFi channel?

Often routers will change their WiFi channel ‘automatically’, either on restart, or update. You might just need to try its 2.4ghz WiFi band on either channel 1, 6 or 11 - if you don’t know how to do that simple change, then you may perhaps find a video on YouTube that explains it, or check your router manual online, or speak to your internet providers support desk. Try each of the three channels to see which is best for your setup. (I recommend trying each channel for approx. 40 minutes at least, as they need time to settle). Once all is okay then just leave it on the selected channel. 
 

Network environments can (and do) often change, so if you encounter the issue in the future then try the different channels again.

Thanks Ken

 

I will look into this. In the meantime, here’s a bit more info. I’ve plugged the beam with a wire cable to the router, that way it works. The I went to sonos app, network settings and removed the wifi network, then add it again. In the app it says it’s successful, but as soon as I remove the wire cable, it takes a few seconds and it goes back to the issue. 
 

I’ll try your suggestion. However I think this is more like a hack though, are you sure this is normal? I never had to do anything like that for any device in my entire life, even in the early 2000’s, it’s a simple wifi connection… should I report this to sonos?

Update. 
 

checked the router config, it was set to channel 6 (auto), whereas sonos was set to channel 1. I’ve changed the router to channel 6 fixed, then while wire connected, changed sonos to channel 6 through the app network settings. Unplugged and so far it’s been working. 
 

Thanks Ken, for saving myself anymore gray hair out of this. Lets hope this stick through now. 
 

I still would expect sonos system to be a little smarter about this, find and set this automatically. Unless that’s intended to sell more of their little wired boost 🤷‍♂️

Spoke to soon. It went back to the issue again. 🤦‍♂️

Frustratedguy,


Just to add that when a sonos device is wired direct to a router, then all Sonos devices should switchover to their own internal SonosNet wireless signal/connection and removing the local WiFi credentials in the Sonos App is a good idea in that type of setup, as it stops the devices hopping between SonosNet and the routers WiFi signal.
 

It’s also best in that ‘wired’ situation to set the routers 2.4ghz WiFi channel and the SonosNet channel so they are at least 5 channels apart to prevent interference between the two signals. 
 

When none of the sonos devices are wired, the SonosNet channel selector should disable, as its irrelevant as all products then connect directly back to the router using the routers 2.4ghz WiFi signal instead.
 

In this situation, I suggest setting the routers 2.4ghz band to use a channel width of 20MHz as that reduces interference aswell.


Many routers appear to like channel 6 by default, so I tend to opt for channels 1 or 11, but it’s really a case of what works best for the local environment. I find that ‘fixing’ a routers channels seems to work best with Sonos and reserving (fixing) each of the Sonos products IP address in the routers DHCP servers reservation table is a very good idea too.

 

This Sonos video about wireless interference is also quite a useful watch:
Wireless Interference and Sonos
 

If your Beam keeps dropping when on WiFi, despite perhaps trying the suggestions above, then when you have it wired back to your router and it reappears in the App I suggest you submit a Sonos system diagnostic report and contact/chat with the Sonos Support Staff via this LINK to see if there are any issues with the Beams WiFi network adapter.

At the end of the day, the only solution was to plug the ethernet cable. 

I confess that I’m only “ok” satisfied with Sonos. I have a Beam, a Sub and 2 One’s. First problem is that it’s extremely hard/impossible to get a One’s speaker separated from the rest, i.e. if I want to move it to another room to play Spotify. Now this. I have several smart home devices and have no similar issues with any of them.

Userlevel 3
Badge +3

At the end of the day, the only solution was to plug the ethernet cable. 

I confess that I’m only “ok” satisfied with Sonos. I have a Beam, a Sub and 2 One’s. First problem is that it’s extremely hard/impossible to get a One’s speaker separated from the rest, i.e. if I want to move it to another room to play Spotify. Now this. I have several smart home devices and have no similar issues with any of them.

I keep having the same problem. But even with Ethernet, the Google Assistant rarely works, and when it does you still have all the annoyances and limitations you get with it on Sonos.

Anyway, if I have a Google Home Mini which cost me $20 where I don’t have to adjust any WiFi settings at all to get it to work and a Sonos speaker which cost me over $200 or even close to $400, where I am told I need to fiddle with settings on my router (and it then still doesn’t work properly after that), something clearly isn’t right here.

And considering Sonos is supposed to be all about usability and simplicity, things couldn’t be more wrong, including the experience with GA on Sonos.

Reply