have to use the app to use roam

  • 4 October 2022
  • 4 replies

Close to taking this junk back. 

Nice build quality and sound. Functionality is less than ideal.


I have to connect with the app or I get “Can’t connect to the internet right now”. Useless.


Setting a wake up alarm for 5:00AM actually sets it for 7:00PM. (Using google assistant). Useless


I spent considerable time looking up the alarm issue. Sonos have known about it for years but won’t fix it.


It worked fine for a couple of months (except for alarms) Have the latest firmware etc. No changes to router etc.


I was looking at a sound bar from Sonos but I think this experience will be enough.

4 replies

I much prefer Alexa and the Sonos Voice Control assistants. They each seems to work better than the Google Assistant and both those other assistants can be installed on the Roam side-by-side - whereas it seems Google want their own assistant to go it alone. The Google implementation is not the best IMHO. I’m currently finding the other assistants work far better by a long-stretch. I think Google really ought to sort out the issues for their customers.

Userlevel 3
Badge +1

You know, in 1997 I took a family trip to Australia for a rugby game. It was our first day there, so we grabbed some quick food at McDonald’s. I had just finished eating when I heard a very bass heavy rumble. It was like the ground was shaking. I looked over, and the gentleman sitting across from us had soiled himself. Absolutely ruined the day.  Anyway, if you’re starting the alarm from google, you roam is just doing what google is sending to it. I don’t use google assistant, but I suspect you may have more than one home, a time zone, or location setting that is causing google assistant to send the incorrect information to the roam.   Both Alexa and Google have some unnecessarily obscure settings that could cause this. Also, the sound bars are great, and being able to play audio to all speakers together is the best part of the Sonos ecosystem.  I hope you can figure out the alarm issue.

Userlevel 7
Badge +17

@Not An Opossum Thank you for painting this picture in my mind…..

@Flippy2022 take al ook at your Google (and maybe Sonos) settings. Is your location set right?

Userlevel 3
Badge +1

@106rallye It turns out the guy was the director of the New Zealand dept of tourism, and a future politician. No surprise. Google and Alexa settings are sort of a mess. I’ve almost eliminated both in favor of just using my phone, automation, or Sonos voice control.