Google home mini default speaker

Show first post

35 replies

I got it to work :)

Step 1: in the Google home app, set your Sonos speaker location as a room that Google home mini is not in (e.g. toilet) hint: room can be fictional

Step 2: create a new routine with a voice command of your choice (e.g. play spotify) that will trigger assistant to: play "name_of_music_service" in the "room_name_from_step_1"

Step 3: enjoy

 *Attached screenshot of my set-up for your reference



Too bad, routines aren't available in my Language (Dutch) 


Only solution I have found and works:

Add chromecast to your TV (living room TV) 

Add Play 5 / Soundbar to your TV

Connect Play ones ( if wanted ) and group them.


Set Default music on google home app as TV (Living Room TV) Make sure your TV's default audio is sonos.

'Hey Google play Bob Marley' 

For me it turns my TV on and Plays through Sonos 👍


I have found no other way, I dont mind my tv being on as it shows what's playing. If you just have play ones, it's not possible so have to stick to 'hey google play Bob Marley on sonos' 

You guys are expecting something very complicated to “just work” because in your minds, it simply should.

From a technical perspective, it is not as simple to make sonos play the audio while the Google Mini does the thinking. All this thinking and answering is computer code. And it’s code that Sonos is unfamiliar with. Sending it to Sonos would fail, because the code is designed to work with a particular speaker (the google home) and because the sonos is not at all designed the same way, the software would not just work. This has always been a problem with AI assistants, and it was why Siri used to be the best assistant (only needed to work on iphones). 

Ask your phone’s assistant the same questions as you do the google mini - you will get the same answers for basic things, but you will get very different answers if your questions/commands are more complicated. They are not the same software. This is the case even though both are written by Google. The developers of the Google Assistant app on android are not the same as the developers of the google assistant on Home, or on anything else, for that matter. And they can’t just take the code from the app and plug it into the Home. Or into the Sonos speaker. It doesn’t work that way.

For the integration to be as smooth as you were expecting, either Google or Sonos needs to design both the speaker and the software. Google would never allow Sonos to do that, but it does allow Sonos or anyone to get a vanilla version of Google Assistant that they then have to make compatible with their Sonos speaker. This takes a lot of work and money, and it will never be a top priority for Sonos. Even with years they spent focused on Alexa, the Alexa integration is not that good either.

It’s not really anyone’s fault; we just have not yet figured out a better way to integrate software with hardware. 

There are apps that try to fill in and do what you want -- but they are essentially tools for you to write your own commands. 

I just moved my Google minis into fictitious rooms ‘upstairs’ and ‘downstairs’ so that there was no conflict with any rooms that physically had both a Google device and Sonos. Then Sonos is the only option in each real room. Seems like the simplest solution?


It looks like we don't have to expect a better integration in de nearby future:

While I agree this functionality would be nice, you can still connect your Google to your Xbox and Sonos, and you can also use the Sonos app to connect your music services and it is pretty similar to “casting”. I use it for my music playing. Just go to Sonos app and connect those services and it works good.

It works since right now:


I tried it with my Google home mini and my playbase. It works!

Userlevel 4
Badge +2

It works since right now:


I tried it with my Google home mini and my playbase. It works!

I tried it with my mini and connect and the setting reverts back to default speaker home mini immediately. Hopefully will resolve itself. 

Userlevel 5
Badge +11

I solved the reverting issue by not returning to the previous page but closing the Google Home app on my iPad after changing the default speaker to a Symfonisk. By doing this the change held.