Google Home does not recognize my S1 Sonos products

  • 28 March 2021
  • 4 replies
  • 35 views

  • Contributor I
  • 2 replies

Hi, My google home no longer recognizes my S1 sonos products (eg Connect:Amp).  In google home I click on the “+” icon (upper left) and select “Set up device” and then “Works with Google”.  Under the list of “Linked services” I do not see sonos.  I then click on the search icon any type in sonos and click on the sonos icon.  A pop up message indicating “Linking your sonos account” appears briefly and then the “Set up a device” screen appears.  When I click on “Works with Google” again, Sonos does not appear in the linked services list.  

All of my software is updated.  I do not see where I can unlink my sonos account from google home.  I though unlinking and then relinking would help.

Thank you in advance.  


4 replies

Userlevel 4
Badge +11

Hi @deg, and welcome to the Sonos Community!

Do you have any other mobile devices with the Google Home app installed? If so, would it be possible to try using a different device?

If there are no other devices available, or if another device doesn’t work, then I’d recommend rebooting your router, Sonos devices, and phone, and then trying once more.

Let us know how you get on :)

Thanks.  I tried what you suggested and still can’t access my sonos devices via google home.

Userlevel 4
Badge +11

Understood, thanks for trying that. 

When trying to link the accounts, does it get as far as requesting your Sonos account details?

If not, it may be worth reinstalling the Google Home app completely and trying once more. If that fails however, I’d recommend getting in touch with our Support Team via either live chat or phone call, so that they can take a closer look at the system.

Since my wife’s phone’s Google Home doesn’t display the Sonos devices, I’m not sure as to why it would be a Google Home issue.  I did reinstall Google Home and still no Sonos devices.  After I click to link my Sonos account with Google Home, there is no additional request for action from me, Google Home returns to the link account screen.  I will contact the support team, thanks.

Reply