Google Assistant - There was a glitch

  • 27 December 2020
  • 1 reply

Hi, my wife bought me a set of Sonos Ones to integrate with our Google Home environment to replace some of their speakers with something with better quality. I’m trying to use them in a multiroom setup and placed one in the Living Room and one in the Den (used the room names from Sonos).

When I installed Google Assistant it works fine on one, but the other one just says “Sorry, there was a glitch” EVERY SINGLE TIME I TALK TO IT.

I tried uninstalling and reinstalling the assistant, assigning the speakers to my wife’s google account, deleting and readding the speaker multiple times, and a bunch of other stuff.

Can someone help? This is INFURIATING why a $30 speaker works flawlessly and my $400 set of speakers with advertised Google compatibility flat out doesn’t.


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 5
Badge +16

Hi @infuriatedcustomer

Welcome to the Sonos community. Thanks for reaching out to us about your concern and letting us know what you have done so far. We appreciate all your effort in resolving this issue.

Let me ask a few questions to help you out with this.

  • When did the issue start happening?
  • Any changes in the network recently like a new router?
  • Have you tried asking Google Assistant on your Den speaker (not using the multiroom setup with your Google Home environment), did you get the same response?
  • How far is your Den speaker from your router?

To investigate further on this, I'd be requesting you to submit a diagnostic from your Sonos systems for us to check. Just include the confirmation number in your response. 

If you need help with any other information, please be sure to let us know. We’ll wait for your reply.