Google Assistant Setup issues with Sonos One (Gen2)

  • 23 December 2019
  • 75 replies


I’ve seen slight variations to this issue on other threads but none that quite address it.


Google assistant was not working on the Sonos One speaker (the microphone was not active and not illuminated).

In an attempt to resolve this issue I unlinked the Sonos from Google and tried re-linking.


Now the situation is that when I go to re-activate the GA service within the Sonos App the following happens:

1.) I'm prompted to add GA to my Sonos

2.) On the "select rooms" page I select the Sonos

3.) I press "add to google assistant" button and I'm re-directed to GA app

4.) This then simply takes me to App Store to purchase/download GA (which I already have)!

5.) When I then go back to Sonos app it says "Linking Google account" and HANGS on this page indefinitely with a spinning wheel. 

6.) After a considerable length of time it times out and says "There was a problem adding google assistant". 


As a work-around for this I've tried adding/linking Sonos from the GA app itself. This is successful in adding the Sonos speaker (e.g. I can tell Google to play music from my phone to the identified/linked speaker and it works), however Google DOES NOT RECOGNISE THIS SPEAKER AS AN ASSISTANT DEVICE. 

Neither GH or GA identify the Sonos as an "Assistant Device". Previously I did have this working but it not longer works at all.

You can see the speaker itself is connected fine, however the ASSISTANT aspect of the speaker is not identified by Google.


Other things I've checked/fixed:

  • Language was the same
  • Default music service same in GH/GA and Sonos (Spotify premium in this case, which I re-authorised)
  • Power cycled Sonos
  • Closed apps and restarted them
  • Removed the Home and created a new one again and linked devices fresh

Any ideas on resolving this would be much appreciated. I’m actually surprised more people haven’t experienced this!


Best answer by alxndrdvl 25 December 2019, 22:07

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

75 replies

Hello @Ronald_vdL. I understand your frustration about Google Assistant, and appreciate the feedback. Are you trying to to add Google Assistant from an iPad by chance? We have noticed a small bug with adding Google assistant from an iPad. As a workaround, are you able to add Google Assistant from your phone? 


Either way, we would like to have you submit a diagnostic of your system and reply back with the confirmation number. This will allow is to see how your system is functioning, and help provide a resolution.

Hi Richard, thank you for picking this up. The diagnostic report number is 538701151


The Google landingpage for “help” is


But it’s non existent. Maybe you have connections with Google to alert them that this doesn’t help

That is strange, we can certainly inform them of any bugs we encounter with Assistant on Sonos and work with them to resolve them. That being said, this appears to be a bug with their support articles. You would need to reach out to them to let them know about that. However, I would give it a day, as they could be performing maintenance on their site, or moving articles around. 


The diagnostic shows that your speaker is getting an inconsistent connection to the internet. How far from the router is this speaker? 

This is extremely frustrating. Google assistant has always worked fine on my device so I recommended my dad to get a Sonos device. So far we’ve been spending three nights trying to get the assistant to work on the device but we keep running into these issues over and over again. There are so many people reporting this problem that Sonos really ought to warn people that this currently broken. 

It would indeed be nice to have some clue of where to start. I tried changing the wifi, but that didn’t work. Installing and re-installing, but no change. I don’t have any device with a previous iOS, but if that would work, I would know where to look for the solution. Then again, if that causes the issue I would expect Sonos/Google to come with an update.

Hello Ronald. I would like to move your case over to our phone team for live troubleshooting. To do so, I am going to send you a direct message for more information. 


@Oeli. Welcome to the Community. Are you having issues adding Google Assistant, or is it not responding when you ask it to perform commands? Would you also mind submitting a diagnostic report, and provide the confirmation number in your next reply?

Hey everyone, looks like the changing URL has worked for most of you, but there’s a potential fix in place now in the latest version of the Google Assistant app. If you’re still having trouble, you can try to delete the Google Assistant App from your iOS device. Then attempt to add Google Assistant from the Sonos app once more, this time you should be guided to "get" the Google Assistant App, tap get and once downloaded discovery should start. If that doesn’t work, trash both the Google Assistant app and also the Google Home App if installed and try again.

Easy and straight forward solution, works perfect for me, thank you!


I am still having issues connecting the Google Assistant. I installed 2 Sonos One speakers and a Playbar as surround system. However, I cannot connect to Google Assistant. Still no fix for this issue?

@BerryV Thank you for bringing your concerns to us here and welcome to the Sonos Community. Have you spoken to anyone in our Dutch Forum? We can see that you tried to submit us a diagnostic report but it is showing as incomplete. We do not know your network topology but I would advise that you do a full wifi network and Sonos product power re-boot off/on for 30 seconds with no lights. When everything is reconnected confirm that your Sonos Ones are setup in their own room names and not part of a surround setup. If they are then remove then as surrounds and confirm in the rooms tab in the Sonos app that they have their own room names. I would then ask that you re-attempt to send us a diagnostic report number and hold on to it.

Next, confirm your Google Assistant is setup in one or both Sonos One units. You can then voice command tests for the weather or a joke and then try a music service. If there are no issues then set them back up as surrounds in your system. If you have any failures in the setup steps or testing the voice commands then follow up here with what issues are happening and at what point in the setups. We will also want to see a second diagnostic report number in your reply.

Lastly, as part of the follow up information needed if you’re having issues is that we will need your full network topology with the model names and numbers of the products that are wired or wirelessly connected on your network for any modem, router(s), extenders, access points or switches (managed or unmanaged).

Dear John, thanks for your response. Based on your feedback, I have been able to install Google assistant on the Sonos One speakers. However, if I try to connect these speakers back to the Playbar and Sub as surround speakers, Google Assistant disappears from the setup. 

I have sent diagnostic information (confirmation nr 803751036) of my set up without surround sound.

I am using an Arris Connect Box Eurodocsis 3.0 modem with 802.11ac Wave 2 wifi-standaard supplied by my provider. In addition an Apple Time Capsule router/access point  with the same SSID and password as the modem. Finally, a Ziggo Next 4K Ultra HD (UHD) decoder for HD TV including playback and cloud storage. The Sonos Playbar is connected to the decoder as my tv does not have a S/PDIF connector.

The following equipment is connected to the network

Apparaatnaam   IP-adres Snelheid (Mb/s) Verbonden via
AppleTV-404     1000 Ethernet
AppleTV-404     1000 Ethernet
Apple Time Capsule     1000 Ethernet
Apple Time Capsule     1000 Ethernet
Miele-     1000 Ethernet
Miele-     1000 Ethernet
Miele-     1000 Ethernet
Miele-     1000 Ethernet
Fibaro HC 2     1000 Ethernet
Fibaro HC 2     1000 Ethernet
SonosZP     1000 Ethernet
SonosZP     1000 Ethernet
EPSONF24430     1000 Ethernet
SonosZP     1000 Ethernet
SonosZP     1000 Ethernet
SonosZP     1000 Ethernet
SonosZP     1000 Ethernet
SonosZP     1000 Ethernet


The Miele connections are kitchen appliances provided with miele@home functionality. 

Hopefully, you are able to provide a solution where I can use my Sonos One speakers together with the SUB and Playbar for surround sound and still have Google Assistant working on the speakers.

Looking forward to your response.


**Moderator Note: Please censor personal information when posting.**

@BerryV Thank you for the follow up information. Your newly supplied diagnostic report shows you have some of your Sonos products on the Apple router and your Arris router wirelessly. You will need to properly configure your network. Who setup your wifi network equipment as in you or an installer? You have two device(s) sending out the network name “Ziggo7678487”.

As a test, please take one of your Play:1’s named Badkamer or Logeerkamer and make one of them the Ethernet wired Sonos product to router you have your device(s) running the Sonos app on wireelssly. Next, power off/on all of your wifi network equipment for 30 seconds with no lights, meaning no battery backup. When they are powering back on then starting with the wired Sonos product power re-boot us off/on for 15 seconds with no lights. While we are powering back on then re-boot the device(s) running the Sonos app. When everything is reconnected then submit us a new diagnostic report number and hold on to it.

When you are back in the app then use these steps to teach Sonos the wireless connection to the router we are wired into with: On iOS or Android: From the Settings tab, tap System > Network > Wireless Setup. Once these steps are then just remove the Ethernet wire from the wired product. Next, test a stream of music grouped to your rooms in the Sonos app to confirm we are playing together. If no issues then attempt to re-add the surrounds to you Playbar.

Please let us know of any issues in the setup steps for the surround along with a new diagnostic report number here.

Lastly, if you are having issues with the surround setup wirelessly then re-wire the Play:1 to the router and power re-boot your surrounds and Playbar off/on for 10 seconds and when reconnected try the surround setup once more with reporting the results here.

@John G . I managed to get everything working following your guodelines. Thanks a lot.

@BerryV Great to hear and thank you for the follow up. Let’s hope that these steps may help other Community users as well. Please feel free to us here with future questions or troubleshooting needs.

The other advice in this thread didn’t work for me, however completely unlinking sonos and google assistant and starting again solved it. 

Unlinking was not as simple as you’d expect:

  1. In the Google Assistant app, click on the compass at the bottom right

  2. Search for Sonos and tap the black Sonos icon

  3. Scroll down and click unlink

Once the accounts are unlinked you can go back to the sonos app and add google assistant through Services and Voice.

I have attached some snapshots. It says ‘Sonos is linked ‘ and ‘account linked successfully ‘ but in actual Fact my Sonos devices are nowhere to be seen. It feels like it wasn’t unlinked properly and I can’t seem to be able to unlink it now 

I have the exact same issue and have got no workable response or resolution from Google or Sonos. They have been unable to tell me how to force unlink the Sonos credentials stored by google even though it does not appear as a linked service in the Home app. More frustrating is that I’m unable to enter my Sonos details because google simply skips this process. However if I use a different google ID/account it all works fine with the usual steps. Did you figure out or get a fix from Google/Sonos?


Changing the link didn’t work for me unfortunately. Here is another way… 

  1. Ensure both Google Chrome and Google Assistant app are installed
  2. Copy and paste the link from Safari
  3. Paste the link in the Chrome app
  4. It should then open in Google Assistant 

@Sonos, please fix this bug.

Userlevel 5
Badge +13

Hey folks, thanks for reaching out. We greatly appreciate you being a part of the Sonos family. It is our pleasure.

Are we still having trouble relating to Google Assistant Setup Problems on iOS, specifically presented with the error "There may be a problem"?

We’re currently tracking that problem and this issue should be resolvable via regular troubleshooting.

Option 1 - Select "Try" again" and it should work. If "trying again" fails:

Option 2 - Submit a diagnostic and reply to us with the confirmation number to check for any obvious issues within the diagnostic.

Option 3 - Use a different controller.

  1. Attempt Setup using a different controller.
  2. Another iOS device or An Android device.
  3. Using an Android device should resolve the issue (be mindful if you borrow an android device, make sure you are using the correct Google Account with the assistant.)

Also, if using an Ipad and the redirect fails .. "Request "Desktop Site" is turned on by default in the Settings app ( Settings > Safari > Request Desktop Site ). When you turn that off, the link should open in the App Store correctly. Use another iOS Controller or an Android Controller.

Let us know how it goes. We and the community are always here to help.




I’ve just added a Beam to my setup using iOS 13.6.1 and Sonos App v 12.0.6. Adding Google Assistant as voice service still fails if the Sonos account is already linked to GA. As it will be if you are expanding an existing Sonos system that is already using Google Assistant.  I had to unlink first to solve it. I expect this to be a very common use case, and I am  surprised that the App or the troubleshooting page at doesn’t mention this. The link says ”4. Make sure your Google Assistant account isn’t in use on another Sonos system”

The actual problem seems to be that GA is in use with THE SAME system (= Sonos account).


Hope this post can help someone else seeing the same issue.

Userlevel 5
Badge +13

Hi @sonos_buron, welcome to the community, and thanks for sharing this with us. I hope I understand this clearly and yes, one Google account can only be used in one Sonos system or one household. If you have an existing system and already using a voice assistant you just have to link the same Google/Alexa account to the Sonos product and it should work flawlessly. 

We greatly appreciate you being a part of the Sonos family. It is our pleasure. Just let us know if you need anything. We and the community are always here to help.

I SOLVED this by unlinking Sonos in my Google Home app > Setting > Works with Google then re-linking. It was like the Google Home App needed to re-negotiate or initiate with my Sonos App/account/devices. 

If you’re using an iOS device switch your default browser to Chrome. The issue seems to be the link in Safari. Process worked flawlessly in Chrome!

I am having switching from Alexa to Google Assistant as the Sonos Voice assistant.


But I am having trouble getting past the part after Sonos directs me to Google Assistant and it begins to search for the services on the same network. It keeps saying it cannot find any devices on the network. Yet they are all connected. Because I can still control my Sonos devices via the Sonos one app.


Please advise.


Diagnostic report: 1976444212


After many months, I finally got past this by installing Alexa first, then switching to Google Assistant.

Now I just wish it would support Chromecast. FFS, the Android experience with Sonos awful.

After many months, I finally got past this by installing Alexa first, then switching to Google Assistant.

Now I just wish it would support Chromecast. FFS, the Android experience with Sonos awful.

How did you get past the "searching for devices on your network" screen? I gave up trying to install GA on my sonos and installed Alexa for Sonos and GA to control everything else in my home.




I was having the same 'no devices found' issue. This time it finally found the device and the only thing different was that I had installed Alexa first. Previously there had been no other voice assistant set up (because GA kept failing the setup) on the Sonos. If you wanted to replicate the circumstances, you might need to factory reset the Sonos first.

Before switching, the Sonos was unlinked in the Google Home app. Previously it appeared in the Google Home devices list even though it was never actually connected or controllable.

I didn't do anything other than installing Alexa first. I appreciate your frustration.