Question

Google assistant responds on both phone and Sonos one


Userlevel 1
I have 2 Sonos ones and a Sonos beam all in different rooms. In general they all work beautifully. I was really looking forward to google assistant since I use this with various other devices. However I've run into a problem which is if my phone (Galaxy S8) in the same room as one of my Sonos devices, both the Sonos and my phone will respond to a hey Google command. I've searched all the various support forums and, surprisingly, I've yet to see this specific issue discussed. My devices are all up to date software - wise and I use the same email address for all my devices and phone. The devices are all found on google home as well. They do respond correctly to commands. The only issue is that both my phone and a device will respond if near to each other, which happens frequently since I tend to keep my phone nearby. How do I fix this? Thanks.

13 replies

Hi Matt, I am having the EXACT same problem.
I know this does NOT happen with Google speakers (Google says your phone should go back to sleep, giving priority to the Home speaker you've enabled with the Assistant).
HOWEVER, this seems to be a BUG with the Sonos smart speakers.
I've tried everything, as far as ensuring the ACCOUNTS for Google Assistant, Google Home, and Sonos are THE SAME. The problem persists.
I really hope the Sonos dev teams reads this thread, because it is a HUGE problem!
Sonos, please fix this.
Best I've come up with is configuring Google assistant on my phone to only respond with voice for hands-free searches. You can find that in the assistant settings.
Userlevel 1
Thanks. That is a limited way to fix the problem since it would preclude using Assistant through my phone. In my mind, Google and Sonos need to get together and make the same type of behaviour with Google Home available to third -party smart speakers such as Sonos.
I have exactly the same problem!!

It used to work flawlessly until a few weeks ago when both my phone and Sonos started to respond to the Assistant commands/queries simultaneously. Really annoying.
I've had this issue from the every start. Any word from Sonos yet? I don't want to go back to Alexa on my sonos.
Userlevel 2
Badge +3
Same issue with my Google Home Mini units. They are far enough away from my Sonos One in other rooms that they don't normally respond when I speak to GA on the Sonos, but occasionally if I speak too loudly or speak from the doorway, the GH Mini in another room responds first, and then the Sonos One in duplication. Same issue if I move my Sonos One to the same room as a GH Mini to listen to music - I can speak to the Sonos One close up, and the GH Mini across the room responds first. I don't think this happens consistently, and maybe it's an issue of the GH Mini having much better microphones. But the real issue is that it shouldn't happen at all, as Google is supposed to be coordinating a single response.

And BTW, the slow response of GA on the Sonos One compared to the GH Mini units is frequently annoying, but it's especially noticeable in this case where there is a duplicate response, with the Sonos being several seconds behind the GH Mini.
I contacted Google and Sonos about this problem. Both told me it's the first they've ever heard of it and both blame the other. Sigh.
I just got a Pixel 3 and set up both of these and turning the phone upside down stops this. Of course then you won't get notifications if you're leaving it like that.
I had just set up Google Assistant on a Sonos One a couple of weeks ago. It seemed to work as it was supposed to at first, but now both my phone and the Sonos always respond, and it is just too annoying. I took the GA off and put Alexa back on.
Userlevel 5
Badge +13
I turned off Google Assistant on my phone, rarely used it anyway and when I do - it's always initiated by tapping on the mic icon in the search field.
Also started happening after I did a software update few weeks ago.
Interestingly mine has started to work properly for the last week or two. Didn't have to do anything to fix it. I guess there must have been an update that fixed the issue for me. :-S
+1. Suddenly fixed itself a day or two ago.

Reply