Google Assistant - No Devices Found

I have 2 Sonos Ones that I am trying to run GA on (Alexa works fine).

I have removed all music services, transferred my Sonos to a Google Account and tried everything, but still the connection is not working. I have followed all the troubleshooting steps and things still don't work.

It seems like this integration needs a lot more polish.

Tried on iOS, Android, failures all around.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

30 replies

Badge +2
Going back to Alexa
I am up and running. It turns out my Cisco Enterprise network was not passing the required MDNS traffic during setup. In order to discover the devices, the Sonos Speaker needs to send MDNS packets (UDP port 5353) to the mobile device doing the setup.

I setup a very old WiFi bridge and connected my mobile device temporarily to that SSID and configured the assistant. They still work once that old SSID is gone.
I changed some settings on my wireless controller and got it to work.

Under the MDNS settings, I need to add the Google Assistant setup with this service string "_gasetup._udp.local." (without the quotes).

I’m having exactly the same problem. Added a L+R pair of Sonos Ones to a new room. Initially added Alexa but it’s very buggy - constantly telling me to wait until later. So I unlinked that and tried to link it to Google Assistant. I have an Android phone. But it can’t find the speakers.

Have a Google Wifi network and I can’t find any mDNS settings to screw with.

I really wish this stuff would “just work”.


The mDNS settings are specifically for an Enterprise Cisco network and would not apply to Google WiFi.

There are a few other threads with suggestions to try that might be more helpful for your situation.