Google assistant: I can't do that here but you can ask me to play it on one of your other devices Sonos


Userlevel 1
Hi there just set up google assistant on my sonos 5.1 and two other sonos ones.

Setup was smooth, but after installation, it gives the following reply whenever I ask Hey google to play music/ spotify etc.

My google music services is the same spotify account as my sonos default. same for the sonos device setting.

I can skip track, pause, stop music once I've launched spotify from my phone etc.

Hope someone can help 🙂

47 replies

I have the same issue.
I've tried to remove and relink the assistant but that didn't help.
me too 😞
I found a solution. My assistant was set up with multiple languages. I was using Swedish as my primary language and US English as a secondary language. Simply swapping the order of these to have US English as the primary language made the Spotify integration work!
Userlevel 3
Badge +2
Same issue here but the language fix didn't work
There's an outage ongoing.

https://status.sonos.com/
Userlevel 3
Badge +2
I get this message when trying to play a radio station via TuneIn.
Has anyone resolved this? I tunein will play fine from assistant on other devices but not from sonos with assistant. Hoping for a fix!
Same here. Disappointing...
Same here. Spent a full hour getting it connected (of course, with Sonos, wifi setup never works and I had to break out the old ethernet cable) and now, it won't play music.

What's the point of voice if it won't play music?

"I can't do that here, but I can play it on one of your other devices". What the hell does that mean?
Userlevel 4
Badge +6
Mine did that yesterday within a Google Assistant routine playing a Sonos favorite radio station I use every day. I tried it again a few minutes later and it was fine again. Totally random.

It seems to be mis-reporting an underlying transient issue.
Badge
I get exactly the same problem, but it usually works if I ask the same question again immediately. It's very frustrating, particular since Google seems much better than Alexa at answering questions.
Userlevel 3
Badge +3
Google assistant keeps a log of everything you ask it in "my activity"
In GA press on your photo, then 3dots to RH corner, then my activity.
You should be able to read what GA thought you said.
I have the same problem. Every time i ask google to play a song og start a spotify playlist, it tells me that it cannot be done on this device. But if I tell it to «play» google starts playing one of my playlists (seems random which one)

i have tried with just english as a primary language, with both english and Norwegian. And with only norwegian.

Any tips?
Badge
It wasn't a problem with understanding the question, I don't think.

I believe I've fixed it, though it might be a coincidence. When I delved deeply enough with the Google Assistant App on my phone I realised that the rear surrounds (Play:1s) paired with my Beam used to have the same names (before they were designated as surrounds) as two new Play Ones which replaced them in other rooms. However, Google Assistant was showing the two phantom speakers. I went through and manually removed all the speakers/rooms from Google Assistant, unpaired/renamed the Play:1s, and then re-added Google Assistant through the Sonos app, and now everything seems to be OK.
It might be worth double checking the language settings in the Google Assistant App “Profile icon (top right)/Assistant Tab/Languages”. See screenshot.

Also worth checking your Sonos Account profile at https://www.sonos.com/myaccount/profile/ (Note: check country setting, part-way down the profile page) the flag icon on the left side of the page is not relevant.

Check that the Sonos devices have been detected and are installed in your Google Home App under the Home Tab ...and if using a Sonos One or Beam device voice-assistant, make sure that the Google voice service is installed in the room settings.

Hope that helps.
I had exactly the same problem. It was because when I linked Sonos with Google Home, I had competing room names. My Sonos was originally called Dining Room and when I linked it with Google I already had a room called Dining Room. Try unlinking the two, then deleting / renaming either your Sonos room or your Google room name, then relink them.
Userlevel 4
Badge +6
I have never tried to group my Sonos One to Google Home speakers, and I don't have any phantom speakers. The transcript from Google Assistant shows that it hears the exact same thing every time I say it - but sometimes it works and sometimes it doesn't.
I’m having the exact same issue: got an email from Sonos saying google assistant now available in Australia so I disabled Alexa and installed Google but it won’t recognise any request associated with playing music even though my Spotify is linked as default service and plays fine on my google mini. Have checked all languages are the same so that’s not the fix. Amazing and frustrating that this bug exists ...
Badge
I am quite sure the problem is not connected with the main language or similar issue.
I had the same problem with Alexa, the problem was Alexa wasn't allowed to use the hardware. To fix it I went to the skill of sonos and I allowed again the skill to control the speaker. Like the android authorization.
The problem is google assistant have not one procedure to authorize it to use the speaker.
I don't know what I can do to authorize the assistant to use it.
I hope someone have one solution, I hate Alexa 😞
Thanks Tapiocapioca - i will try this too. what do you mean when you say you “went to the skill of Sonos”? Is there an alternative way to interpret/explain what you mean? Any extra detail would be much appreciated. Many thanks
Badge
Same issue worked fine for a few days and now this same response. Sonos please fix this its something that a large customer base is encountering with no acknowledgement of the issue.
Userlevel 7
Badge +20
Same issue worked fine for a few days and now this same response. Sonos please fix this its something that a large customer base is encountering with no acknowledgement of the issue.

Hi there,

Currently there is an outage which is affecting Google Assistant use on Sonos. Keep an eye on our status page for more information.
Userlevel 1

I think I have found the cause of this on my system. I had moved the SONOS One to a new room and reset the speaker, reconnected to the WiFi and then added the voice service for Google. Since then I got the “I cant do that here”  message. When I went into the Google Assistant app and checked under settings/ devices there were duplicates for the SONOS One under Assistant Devices. I solved the problem by deleting ALL the SONOS entries and then gong back to the SONOS app and re-adding the voice service.

 

hope this helps.

Thanks PaulHill

Just what I needed. :-) You have saved my day

 

Duplicate device/room names was the problem for me too. I removed all the Sonos entries in the google assistant app and then re-added my current speakers, and now it works more or less perfectly. 
 

Reply