Google Assistant does not work any longer

  • 25 November 2020
  • 7 replies

  • Contributor I
  • 5 replies

Hi there!

I have a Google Assistant related issue--my Sonos System (Arc, Sub+Move) is linked to Google Assistant and everything worked perfectly fine so far. A few days ago I had to restart all devices as they were not found in the Sonos App. Google Assistant is still linked to my Sonos Move but does not work any longer (Assistant is not available).


The Arc has no Google Assistant linked any longer and is also not found when I try to locate it both over the Google Home and Sonos App.


Thanks for your help!


As I did not change anything and it stopped working I guess this is related to the latest Software Update?!

Btw I have also sent a diagnostic report with ID 257824096. Maybe you can see what went wrong.


7 replies

Userlevel 5
Badge +14

Hi @JoRa.

Welcome, thank you for reaching out to Sonos Community and providing the diagnostic report, I totally understand where you're coming from and I’m here to help.

Can you try to remove the Google Assistance in Sonos move then try to re-add it again in the Sonos application?

Let us know if it works. If you need help with any other information, please be sure to let us know.

Hi @Mark P -thanks for your answer. Already removed  Google Assistant from my Move and re-added it. Unfortunately this did not change the behaviour: The Move reacts to the keyphrase but then tells me that Assistant is not available at the moment.


Sonos Arc is neither found as a google Assistant supported device nor reacts to the keyphrase.

Update: I just tried to remove and re-install the Assistant and now also the move is not found any more :/


Update 2: Google Assistant finds the Move again and seems to work there...nevertheless Arc is still not recognized nor found

I have the same issue, Google Assistant will stop working after a week or so.  The “Fix” is to remove it and re-add the service.   Stop working means it does not respond to Hey Google.  The ARC is working perfectly with everything else.


This happened via Wifi, so I switched it to hard wired… I still have the same issue happening over and over.  It works great for 10days or so...then just stops.  The app shows it installed.  Removing it and adding it restores the service.

I’ve opened a support ticket and have sent my diagnostic info.

Similar problem here. Since a few days (since the last app update?), when I say “Hey, Google”, my One or Move responds with “Sorry, something went wrong. Try again in a few seconds.” or “There was a glitch. Try again in a few seconds.”. I tried removing and re-adding Assistant to SONOS, but this didn’t help.

I also own some Google Home Minis, they work without a problem...


Never mind, I unlinked my SONOS account from Google Home and linked it again. Now it’s working...


Just went through this mess as well, so thought I'd share the solution:


My sequence was:

1) existing S1 setup - no Google Assistant capable device

2) added Move to S1 setup, configured the Assistant fine

3) added Arc to the system, which triggered the entire migration to S2 (rendering about 4 legacy speakers useless)

4) had to reset Move to re-add to S2 setup with Arc

5) Move played music, but Assistant feature stopped

6) Google Home app couldn't find neither Arc nor Move to set up Assistant


Finally realized that while the S1 network wasn't Assistant capable, someone had added one of the now defunct Play5 speakers as an audio device. Since that speaker wasn't plugged in, it didn't show up even on any migration related lists.


Unlinking Sonos from Google Home completely, and triggering a new re-linking via S2 app finally found Arc & Move.


Bottom line: if you have done S1-S2 migration too, get rid of the legacy connection between Google & Sonos, it will block the new devices finding.