Question

Google asistant can't find device

  • 20 April 2020
  • 4 replies
  • 402 views

Hello I’m having trobule setting up Google Assitant on my Sonos one speaker. This is the only device I got from sonos. I’m stuck on finding devices part.
 

 


4 replies

Same problem here. No help from Sonos. 

@Sourtoast @Mthorsager Sorry for the slow reply and thank you for bringing your concerns to the Sonos Community. @Mthorsager can you be more specific as to what your issue is with the voice service setup of Google Assistant or Amazon Alexa on your Beam.

@Sourtoast We will need more information about your wifi network as the diagnostic report and report number we can see from your system are incomplete and not coming through to us. This is usually an indication of performance issue(s) with the network for Sonos to communicate on. I would ask/stress that you avoid doing any factory resets to your Sonos products as they are not a recommended troubleshooting step unless on a phone call, email or social media chat. Please understand that the voice service feature is cloud based meaning the Google or Amazon server needs to be able to see and speak to the Sonos server. We will need your network topology with the model names and numbers of the products that are wired or wirelessly connected on your network for any modem, router(s), extenders, access points or switches (managed or unmanaged).

Once you have gathered that information then please power re-boot off your wifi equipment for 30 seconds with no lights on it, meaning no battery backup, then power it back up. While this equipment is powering back on then power re-boot off your Sonos units for the same time with no lights and then plug them back in to power, no button pressing is needed. Lastly, re-boot the device running the Sonos and Google Assistant apps. When everything is re-booted and you can connect back into the app then test voice service setup once more for Google Assistant. You can then follow up here with the setup results and new diagnostic report number here.

Hello John G. One from your support told me that I should try to make a new Google account. With the new account, Google Assistant could now find the Sonos Beam. Then I tried to switch back to the old account, Google Assistant was still able to find the Sonos Beam. So my problem is solved. /Mthorsager.

@Mthorsager Thank for the follow up to let us know you’re working now. Feel free to reach out in the future to the Sonos Community with your questions or troubleshooting needs.

Reply