Cant add Sonos skill to google assistant "Register speakers"

  • 3 February 2024
  • 10 replies
  • 383 views

  • Contributor I
  • 2 replies

Today I removed connection to Sonos from the Google Home app (I have 9 speakers). I added it again in the Google Home app and it all worked. At this point i noticed that a few of my speakers had Google assistant missing. I tried to add it from the Sonos app, and it did not work. I decided to remove the connection from Google Home app and re-add it, and this failed with the following error message:

 

"Register your speakers

You need to link speakers to your myemail@hotmail.com Sonos account before you can add this skill.

Go to More > Settings > Account Settings in the Sonos app. (If you don't see Sonos Account, your Sonos system needs an update.)"

 

I have the system working with all the speakers and thet seem registered on the Sonos webpage.

I have tried everything. Rebooted my network totally, rebooted my sonos system, deleted and re-created my home in Google home, but it all results in the same error. The Sonos tech support guy in the chat told me to remove all Sonos devices from Google home app. The thing is that the devices all disappeared when i removed the connection to Sonos from google home so there is nothing to remove.

 

I don't have any DNS service going on. Is anyone able to help?

 


10 replies

I have the same issue but with Alexa today. Is it a Sonos side problem? Very frustrated 

FYI - mine is a new set up with just one speaker (Five)

I got mine too work by just waiting. Suddenly (6 hrs in) o was able to add the Sonos skill from Google Home. However seems like something happened to my sonos account, it says it was created today, and thats not true. It was like 10 years ago.

 

Next issue, I cant add google assistant from the Sonos App to my four devices with support for google assistant.

 

Translation from Swedish: "A problem occured when adding google device"

 

Please help?

Same issue. Google and Sonos are not connecting

 

Ok, I found a workaround to add the google assistant to the speakers. I am on Android. I killed the google app and the Sonos app completely. (Enter App information and force kill both apps). 

 

Then I could add the assistant from the Sonos app, one speaker at a time. For each speaker I needed to do the "kill" process. Not a flawless experience but now it seems to work.

 

 

I also have been having this problem for several months. I called Sonos support, and they worked with me for about two hours. To no avail. Sometimes Alexa will connect the skill to Sonos. Sometimes I get the same error as above. When it does connect to the Alexa skill, she works about a quarter of the time or fewer options. This is very frustrating and unacceptable for the amount of money. We’ve all spent on these systems.

I’ve seen the issue reported when completely removing/reinstalling the Sonos Skill in the Alexa App manually - see screenshot attached for example of the error message 

To resolve this issue, perhaps try removing and/or (re)installing the Alexa Assistant onto any compatible Sonos speaker via the Sonos App - you may receive an error message, but click to retry - it should then install the Sonos skill in the Amazon Alexa App automatically and resolve the issue seen. At least that’s what worked for me.

I’d like to post an update. Last night I spent about four hours, deleting everything and reinstalling everything. That included disassociating all of my echo devices disassociating all of my Sonos devices and re-adding everyone of them. I signed out of all apps related to Amazon, Sonos and Spotify. on every device I own. I waited an hour as Spotify sometimes takes a while to fully remove itself from everything. I then reinstalled everything and surprisingly Amazon Alexa finally worked with the Sonos skill. Everything is working just fine for about an hour, and then it broke. I thought if I just disable the Sonos skill and reenable it, maybe that would work. Hoping that just by doing that, things would get back to normal again. Unfortunately, no I got the same “ you need to register speakers” error. I do not own a Sonos speaker with an echo installed. 

@Icepick 

There does seem to be the occasional issue here as the screenshot in my last post shows, but not sure if it’s an Amazon or Sonos issue. Things are still working okay for me but, I’m a little reluctant to remove the Sonos Skill if things do go awry.

Maybe the Sonos Staff here will see this and pass things along to check if there is an issue with the account sharing token process.

Thank you Ken. I hope by saying this, I don’t screw something up but all morning Sonos was not working through Alexa. I left for the afternoon and I came back this evening, and I asked Alexa to shuffle my liked songs, and she started playing my liked songs on Sonos. I don’t understand why it works sometimes and not others but it is very frustrating and I really really hope whoever Can fix fixes this problem because I don’t think it’s a user error problem. 

That fix worked for about two hours. Back to before where Alexa does not control Sonos.

Reply