Answered

cannot add Google Assistant to Sonos Roam

  • 16 January 2024
  • 7 replies
  • 189 views

cannot add sonos roam as goggle assistant tried reset tried reinstalling the app nothing works

icon

Best answer by Schlumpf 16 January 2024, 15:23

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Userlevel 7
Badge +14

@Shawngoes 

To get help you should give some more information. What in detail does not work as expected? At which point does it stuck? Is there an error message? 

It gets stuck here my Google account and sonos account is linked to same email address 

Userlevel 7
Badge +14

@Shawngoes 

It‘s not necessary to use the same email address for your Sonos account as for your google account. But you can do if you like. 
Did you try logging out from your Google Account and logging in again during the installation of GA?

If you open your Google Home app is your Sonos device visible there as a speaker? If so try removing it completely from Google Home and try again. 

On the Google home app there's no sonos device visible as a speaker I tried logging out of the home app and GA and tried again but no luck 

 

Userlevel 7
Badge +14

@Shawngoes

Ok, this looks strange as you obviously are logged in to your Sonos account. Maybe logging out and in again could help, but to get this solved I suggest to call Sonos support. 
Have you changed your Sonos account email address recently? If so a system restart and re login would be worth a try. 

check the address in your Sonos matches what’s in your google home

@Shawngoes after you check the above, go to your Sonos app - App preferences scroll all way down - Reset App.

close the app on your phone and reopen it again

at this point there should be no system or account.

Go to services and Voice - you should then have a pop up that asks you to login do so.

- click add voice - choose google assistant

Go to your google home - add devices - works with google - search for sonos - select - continue- sign in to your sonos account - allow - go Okay - linking your sonos account

 

You should now see your speaker - click done