Answered

Can't use Google Assistant to control Spotify on Beam


When I ask Google to play a song on Spotify through my Beam, it will say: "OK, here's [song]. Sorry, it looks like you haven't set up Spotify on your Sonos app. To play from Spotify, link the same account on both Sonos and Google Assistant." I have linked and unlinked the same account on both the Sonos app and the Google Assistant app a number of times, and still can't get it to work. Is there something I'm missing?
icon

Best answer by Ken_Griffiths 20 May 2019, 00:09

Then it's perhaps best to make contact with Sonos Customer Care. Hope you get it sorted soon.👍
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

gpp210,

Just to clarify, is there only just the one Spotify premium account involved in your household and installed on your devices?
Yes, that's correct - there's only one Spotify premium account in my household.
Is the google Home (where Spotify is presently installed and set as the default MSP), one that you actually created in your google account, or is it one a partner may have created and you have then added your account to that Home?

If it’s your Home and that’s all okay, then...

Ensure that your Google App language settings are set to English (United States) and then try unlinking and re-linking the Sonos device/skill again making sure all Sonos devices are removed from your HOME before reinstalling.

Then check that the Google Assistant voice service is installed on your Sonos One/Beam device(s) (as required) by checking the voice service section in their “Room Settings” in the Sonos App.

Hope that gets you up and running.👍
Thanks, went through all of those steps, still no success.
Then it's perhaps best to make contact with Sonos Customer Care. Hope you get it sorted soon.👍
Just curious if you have solved your issue, I am having the exact same problem.
Ok, I have to say that it works this morning. I didn’t do anything particular, just woke up and decided to give it a try, and voila.

Magic? Maybe an outage that got resolved...