Beam Gen 2 can't play Spotify via Google Assistant voice command

  • 20 May 2024
  • 1 reply

Recently got the Beam Gen 2 and couldn’t be happier...until I tried playing Spotify via Google Assistant voice command. Every time I say “Hey Google, play XXXXX on Spotify”, it just says “Ok, playing XXXXX on Spotify. Sorry, Spotify Premium isn’t currently available.” Have tried everything, including the following steps:

  • Unlinked and relinked everything multiple times — Sonos app, GA and Google Home.
  • Ensured voice integration is sorted — all other GA commands work fine.
  • Spotify set to preferred music streaming on Sonos app and GA.
  • Checked that it’s indeed Spotify Premium account.
  • Even created a new dummy account from a free Spotify Family plan.

Any advice?

1 reply

Update to my problem:

Finally sorted out the above. Basically, I had to log in to the Spotify website on desktop, go to Account > Manage Apps > "Remove access" to Sonos. After that, I re-added Spotify to my Google Assistant and Sonos, checked that it's reflected on the Spotify "Manage Apps" page, and it worked like a charm.

Hope this helps whomever is facing the same issue.